Element and Attribute Documentation

MSR-MEDOC

Element and Attribute Documentation
MSRREP V2.2.2 (multi language)
[eadoc]
Revision: 1
This document describes MSRREP-222 ML DTD. It is intended to serve as a DTD reference and a global description of semantics.


I. Document management

Element and Attribute Documentation
I. Document management

Team members
Name | Company | {CONTACT}
Herbert Klein | MSR-MEDOC | Department: XI-Works
Version overview
Version | Date | Editor | State
1 | 2005-06-25 | Herbert Klein | WD
Modifications
Version | Change | Related to
1 | Merge of decriptions from MSRSW V2.3.0 Reason: Inital Version | Content
Modifications included
Date | Chapter | Change | Related to
2005-06-25 | Gesamt | Merge of decriptions from MSRSW V2.3.0 Reason: Inital Version | Content


1. Standard Attributes

Element and Attribute Documentation
1. Standard Attributes
See Also Description Example Formal Description

Description
These attribute are so called Standard Attributes since they occur on every element within the DTD. They will only be described here to save document space.
Example
Formal Description
Name | Type | Values / Default | Notes
[S] (implied) | cdata |  | Signature under which the calculated signature belonging to the contents of an element, can be stored, e.g. CRC.
[SI] (implied) | cdata |  | Description of the semantic meaning of an element.
[T] (implied) | cdata |  | Time stamp specification
[VIEW] (implied) | cdata |  | Arbitrary term for realization of a conceptual view. In this way, text components can be inserted or masked out in editor, or when a document is generated.


2. Elemente der MSRREP DTD

Element and Attribute Documentation
2. Elemente der MSRREP DTD


2.1. ABS
See Also Description Example Formal Description

Description
Use <ABS> to enter the absolute values of a parameter in a parameter table.
Example
<ABS>5</ABS>
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.2. ABSTRACT

Description
You can use <ABSTRACT> to give a short summary on the document which is formatted in the first pages of the document.
Example
<ABSTRACT>
  <P>This document describes MSRREP-222 DTD. It is intended to serve
     as a DTD reference and a global description of semantics.</P>
</ABSTRACT>
Formal Description
Within context of: | REPORT-HEAD
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2, TOPIC-2, MSR-QUERY-TOPIC-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.3. ADD-INFO-5

Description
<ADD-INFO-5> has the same purpose as the <ADD-INFO> element and gives the opportunity to provide additional information to a structure in the form of continuous text. The only difference is that <ADD-INFO-5> has a limited set of elements. The information can only be entered in one level since no subchapters or topics are available.
Example
This sample show how some information has been added to describe a Service Argument.
<SW-SERVICE-ARG>
    <LONG-NAME>Temp Input Value</LONG-NAME>
    <SHORT-NAME>gTemp</SHORT-NAME>
        <SW-DATA-DEF-PROPS>
            <SW-BASE-TYPE-REF>real32</SW-BASE-TYPE-REF>
        </SW-DATA-DEF-PROPS>
        <ADD-INFO-5>
            <P>It might seem unnecessary to take the gTemp into account, but....</P>
        </ADD-INFO-5>
 </SW-SERVICE-ARG>
Formal Description
Within context of: | SYN-ARGUMENT, SYN-EXAMPLE, SYN-RETURN-VALUE, SYN-SEMANTICS
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, MSR-QUERY-P-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.4. ADDRESS

Description
Use <ADDRESS> , to enter the street name of the company address, e.g. where a project participant is located. One line can be entered since all carriage returns typically are ignored.
Example
<ADDRESS>Quilt Steet 43</ADDRESS>
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.5. ADMIN-DATA

Description
<ADMIN-DATA> can be used to set administrative information for an element. This administration information is to be treated as metadata such as revision id or state of the file. There are basically four kinds of metadata
  • The language and/or used laguages.
  • Revision information covering e.g. revision number, state, release date, changes. Note that this information can be given in general as well as related to a particular company.
  • Document metadata specific for a company
  • Formatting controls that can affect layouts for example.
  • Revision information for the element.
Example
This sample shows how the language and some revision information has been defined for an element.
                <ADMIN-DATA>
                   <LANGUAGE>en</LANGUAGE>
                   <DOC-REVISIONS>
                      <DOC-REVISION>
                         <REVISION-LABEL>2</REVISION-LABEL>
                             <STATE>review-candiate</STATE>
                         <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
                         <DATE>15.8.2001</DATE>
                         <MODIFICATIONS>
                            <MODIFICATION>
                               <CHANGE>fixed typos</CHANGE>
                               <REASON>typos were found in the internal review</REASON>
                            </MODIFICATION>
                         </MODIFICATIONS>
                      </DOC-REVISION>
                      <DOC-REVISION>
                         <REVISION-LABEL>1</REVISION-LABEL>
                         <STATE>initial draft</STATE>
                         <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
                         <DATE>12.8.2001</DATE>
                         <MODIFICATIONS>
                            <MODIFICATION>
                               <CHANGE>Created the document</CHANGE>
                               <REASON>According to video-conference held at Jul2001</REASON>
                            </MODIFICATION>
                         </MODIFICATIONS>
                      </DOC-REVISION>
                   </DOC-REVISIONS>
                </ADMIN-DATA>
Formal Description
Within context of: | CHAPTER, CHG-CHAPTER, MSRREP
Is context for: | LANGUAGE, USED-LANGUAGES, COMPANY-DOC-INFOS, FORMATTER-CTRLS, DOC-REVISIONS
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.6. AREA

Description
This element specifies a region in an image map. Image maps enable authors to specify regions in an object (e.g. a graphic) and to assign a specific activity to each region (e.g. load a document, launch a program etc.).
Example
  <AREA SHAPE="RECT" COORDS="63,28,99,46" HREF="msrrep-id:EADOC-SUP"/>
Formal Description
Within context of: | MAP
Has no contents. |
Name
Type
Values / Default
Notes
[SHAPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • RECT
  • CIRCLE
  • POLY
  • DEFAULT
The interpretation of the coordinates [COORDS] is controlled by the value of [SHAPE] .
[ACCESSKEY]
optional
String (CDATA)
This attribute assigns an access key to an element. An access key is an individual character (e.g. "B") within the document character range. If an access key with an element assigned to it is pressed, the element comes into focus. The activity performed when an element comes into focus, is dependent on the element itself.
[ALT]
optional
String (CDATA)
This attribute specifies the text to be inserted as an alternative to illustrations, shapes or applets, where these cannot be displayed by user agents.
[CLASS]
optional
String (CDATA)
Blank separated list of classes
[COORDS]
optional
String (CDATA)
This attribute specifies the position and shape on the screen. The number of values and their order depend on the geometrical figure defined. Possible combinations are:
[HREF]
optional
String (CDATA)
This attribute specifies the memory location of a web resource. It is therefore able to specify a link between the current element and the target element.
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[NOHREF]
optional
Value selection (NAMEDTOKENGROUP)
  • NOHREF
If this attribute is set, <AREA> has no associated link.
[ONBLUR]
optional
String (CDATA)
The ONBLUR-Event occurs, when focus is switched away from an element. A script can be stored in this attribute to be performed in the Event.
[ONCLICK]
optional
String (CDATA)
The ONCLICK-Event occurs, if the current element is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONDBLCLICK]
optional
String (CDATA)
The ONDBLCLICK-Event occurs, if the current Event is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONFOCUS]
optional
String (CDATA)
The ONFOCUS-Event occurs, if an element comes into focus (e.g. through navigation using the tab button). A script can be stored in this attribute to be performed in the Event.
[ONKEYDOWN]
optional
String (CDATA)
The ONKEYDOWN-Event occurs, if a button on the current element is pressed down. A script can be stored in this attribute to be performed in the Event.
[ONKEYPRESS]
optional
String (CDATA)
The ONKEYPRESS-Event occurs, if a button on the current element is pressed down and released. A script can be stored in this attribute to be performed in the Event.
[ONKEYUP]
optional
String (CDATA)
The ONKEYUP-Event occurs, if a button on the current element is released. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEDOWN]
optional
String (CDATA)
The ONMOUSEDOWN-Event occurs, if the mouse button used for clicking is held down on the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEMOVE]
optional
String (CDATA)
The ONMOUSEMOVE-Event occurs, if the mouse pointer is moved on the current element (i.e. it is located on the current element). A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOUT]
optional
String (CDATA)
The ONMOUSEOUT-Event occurs, if the mouse pointer is moved from the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOVER]
optional
String (CDATA)
The ONMOUSEOVER-Event occurs, if the mouse pointer is moved to the current element from another location outside it. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEUP]
optional
String (CDATA)
The ONMOUSEUP-Event occurs if the mouse button used for clicking is released on the current element. A script can be stored in this attribute to be performed in the Event.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[STYLE]
optional
String (CDATA)
Information on the associated style
[T]
optional
String (CDATA)
[TABINDEX]
optional
String (CDATA)
This attribute specifies the position of the current element in tabbing-order for the corresponding document. The value must lie between 0 and 32767. The Tabbing Order defines the sequence in which elements are focused on, when the user navigates using the keyboard.
[TITLE]
optional
String (CDATA)
Title information of the <AREA> -element
[VIEW]
optional
String (CDATA)


2.7. BR

Description
This element is the same as function here as in a HTML document i.e. it forces a line break.
Example
<P>The first row<BR/>the second row</P>
Formal Description
Within context of: | L-1, L-5
Has no contents. |
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.8. C-CODE

Description
Use <C-CODE> to insert a formula defined as C-Code.
Example
Formal Description
Within context of: | FORMULA
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.9. CATEGORY

Description
This element assigns a category to the parent element. The category can be used by a semantic checker in post-processes to ensure that the parent object is defined correctly i.e. has the right number of elements for example.
Example
This example shows how <CATEGORY> is used to qualify a calibration parameter as a map. Further processing could now establish whether two axes also has to be specified.
<SW-CALPRM>
                   <SHORT-NAME>KF_XYZ</SHORT-NAME>
                   <CATEGORY>MAP</CATEGORY>
                   ...
                <SW-CALPRM>
Formal Description
Within context of: | CHG-REQUEST, MSRREP, SYN-CAPTION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.10. CHANGE

Description
<CHANGE> is used to enter a modification text for a <MODIFICATION> element. The element has the same contents and features as a normal Pararagraf element <P>.
Example
<CHANGE>This code is now optimized for <TT TYPE="PRODUCT">C#</TT>.</CHANGE>
Formal Description
Within context of: | MODIFICATION
Is context for: | L-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.11. CHANGES

Description
Change manangement support is provided using <changes>. This allows to maintain multiple change mananagements within one document.
Example
Formal Description
Within context of: | CHG-CHAPTER
Is context for: | CHG-OBJECTS, CHG-REQUESTS
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.12. CHAPTER

Description
Use <CHAPTER> , to create a chapter structure.
Example
Formal Description
Within context of: | CHAPTER, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-CHAPTER, REPORT-BODY, REPORT-HEAD, REPORT-REAR
Is context for: | LONG-NAME, SHORT-NAME, ADMIN-DATA, INTRODUCTION, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name
Type
Values / Default
Notes
[BREAK]
optional
Value selection (NAMEDTOKENGROUP)
  • BREAK
  • NO-BREAK
Select BREAK to insert a page break ahead of the chapter title.
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the parent element. The syntax has its origins in the help system utilized. This is often used to calculate an object ID or a widget name hierarchy from a window system, which is then correlated with the help entries.
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
CHAPTER
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.13. CHG-ACTION

Description
Example
Formal Description
Within context of: | CHG-ACTIONS
Is context for: | DESC, CHG-RESPONSIBLE, DATE
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.14. CHG-ACTIONS

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | CHG-ACTION
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.15. CHG-CHAPTER

Description
<CHG-CHAPTER> is a chapter which contains only change manangement documenation. <CHG-CHAPTER> can occur multiple on the chapter toplevel(1., 2., 3.). This allows to maintain multiple change mananagement sets within one document.
<CHG-CHAPTER> is treated like a normal <CHAPTER> in <REPORT-BODY> an is numbered in the same way.
Example
Formal Description
Within context of: | REPORT-BODY
Is context for: | LONG-NAME, SHORT-NAME, ADMIN-DATA, INTRODUCTION, CHANGES
Name
Type
Values / Default
Notes
[ID]
optional
ID (ID)
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[F-ID-CLASS]
fixed value
String (CDATA)
CHAPTER
[F-NAMESPACE]
fixed value
SGML strings (NMTOKENS)
CHG-OBJECT CHG-OBJECT-REVISION CHG-REQUEST


2.16. CHG-CONCLUSION

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | CHG-SOLUTION-SPEC, CHG-IMPLEMENTATIONS
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.17. CHG-EFFORT

Description
Example
Formal Description
Within context of: | CHG-SOLUTION-SPEC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.18. CHG-IMPLEMENTATION

Description
Example
Formal Description
Within context of: | CHG-IMPLEMENTATIONS
Is context for: | CHG-OBJECT-REVISION-REF, CHG-RELEASE-NOTES
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.19. CHG-IMPLEMENTATIONS

Description
Example
Formal Description
Within context of: | CHG-CONCLUSION
Is context for: | CHG-IMPLEMENTATION
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.20. CHG-KEYWORD

Description
Example
Formal Description
Within context of: | CHG-KEYWORDS
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.21. CHG-KEYWORDS

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | CHG-KEYWORD
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.22. CHG-OBJECT

Description
Example
Formal Description
Within context of: | CHG-OBJECTS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CHG-OBJECT-REVISIONS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | String (CDATA) | CHG-OBJECT |
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | CHG-OBJECT-REVISION |


2.23. CHG-OBJECT-REVISION

Description
Example
Formal Description
Within context of: | CHG-OBJECT-REVISIONS
Is context for: | LONG-NAME, SHORT-NAME, DESC, DATE, CHG-STATE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | String (CDATA) | CHG-OBJECT-REVISION |


2.24. CHG-OBJECT-REVISION-REF

Description
Example
Formal Description
Within context of: | CHG-IMPLEMENTATION, CHG-RELATED-OBJECTS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | CHG-OBJECT-REVISION |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.25. CHG-OBJECT-REVISIONS

Description
Example
Formal Description
Within context of: | CHG-OBJECT
Is context for: | CHG-OBJECT-REVISION
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.26. CHG-OBJECTS

Description
Example
Formal Description
Within context of: | CHANGES
Is context for: | CHG-OBJECT
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.27. CHG-PRIORITY

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.28. CHG-PROPOSED-BY

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.29. CHG-REASON

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.30. CHG-RELATED-OBJECTS

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | CHG-OBJECT-REVISION-REF
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.31. CHG-RELATED-REQUESTS

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | CHG-REQUEST-REF
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.32. CHG-RELEASE-NOTES

Description
Example
Formal Description
Within context of: | CHG-IMPLEMENTATION
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.33. CHG-REQUEST

Description
Example
Formal Description
Within context of: | CHG-REQUESTS
Is context for: | LONG-NAME, SHORT-NAME, CATEGORY, DATE, CHG-STATE, CHG-PRIORITY, CHG-KEYWORDS, CHG-PROPOSED-BY, CHG-RELATED-OBJECTS, CHG-RELATED-REQUESTS, CHG-SUBJECT, CHG-REASON, CHG-ACTIONS, CHG-SOLUTIONS, CHG-CONCLUSION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | String (CDATA) | CHG-REQUEST |


2.34. CHG-REQUEST-REF

Description
Example
Formal Description
Within context of: | CHG-RELATED-REQUESTS
Is context for: | Text
Name
Type
Values / Default
Notes
[RELATION]
required
Value selection (NAMEDTOKENGROUP)
  • PREREQUISITE
  • OTHER
[ID-REF]
optional
ID reference (IDREF)
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
CHG-REQUEST
[HYNAMES]
fixed value
SGML strings (NMTOKENS)
LINKEND ID-REF
[HYTIME]
fixed value
SGML string (NMTOKEN)
CLINK


2.35. CHG-REQUESTS

Description
Example
Formal Description
Within context of: | CHANGES
Is context for: | CHG-REQUEST
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.36. CHG-RESPONSIBLE

Description
Example
Formal Description
Within context of: | CHG-ACTION
Is context for: | Text, TEAM-MEMBER-REF
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.37. CHG-SOLUTION

Description
Example
Formal Description
Within context of: | CHG-SOLUTIONS
Is context for: | CHG-SOLUTION-SPEC, CHG-SOLUTION-PRO, CHG-SOLUTION-CON
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.38. CHG-SOLUTION-CON

Description
Example
Formal Description
Within context of: | CHG-SOLUTION
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.39. CHG-SOLUTION-PRO

Description
Example
Formal Description
Within context of: | CHG-SOLUTION
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.40. CHG-SOLUTION-SPEC

Description
Example
Formal Description
Within context of: | CHG-CONCLUSION, CHG-SOLUTION
Is context for: | CHG-EFFORT, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.41. CHG-SOLUTIONS

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | CHG-SOLUTION
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.42. CHG-STATE

Description
Example
Formal Description
Within context of: | CHG-OBJECT-REVISION, CHG-REQUEST
Is context for: | Text
Name
Type
Values / Default
Notes
[STATE]
has default value
Value selection (NAMEDTOKENGROUP)
  • OPEN
  • PASSED
  • REJECTED
  • IN-PROCESS
  • DONE
  • POSTPONED
  • RELEASED
  • WITHDRAWN
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.43. CHG-SUBJECT

Description
Example
Formal Description
Within context of: | CHG-REQUEST
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.44. CITY

Description
Use <CITY> to enter the city in the company address where a project participant is located.
Example
<CITY>London</CITY>
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.45. COLSPEC

Description
Use <COLSPEC> , to insert and specify a column in a table.
Example
<COLSPEC COLNAME="col1" COLNUM="1" COLWIDTH="1.00*"/>
Formal Description
Within context of: | TFOOT, TGROUP, THEAD
Has no contents. |
Name
Type
Values / Default
Notes
[ALIGN]
optional
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
optional
String (CDATA)
If [ALIGN]="CHAR", this one-character value of [CHAR] specifies the alignment sign e.g. "bzlw", as a decimal point separator. The sign cannot be a SDATA entity.
[CHAROFF]
optional
SGML string (NMTOKEN)
If [ALIGN]="CHAROFF", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <COLSPEC>, alignment is always horizontal right. The default value is taken from <TGROUP> .
[COLNAME]
optional
SGML string (NMTOKEN)
Now, specify an identification name for the column that has been modified, e.g. column1 for the first one.
[COLNUM]
optional
SGML string (NMTOKEN)
At this point you should specify the placement of the modified column within the table, e.g. 1 for the first column.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[COLWIDTH]
optional
String (CDATA)
Next, specify the width of the modified column in the table. You can enter absolute values such as 4 cm, or relative values marked with *, e.g. 2* for column widths double those of other columns.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.46. COMMENT

Description
This element contains a commentary in text form.
Example
<COMMENT>This section is maintained by John.</COMMENT>
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.47. COMPANIES

Description
<COMPANIES> can be used to describe the companies involved in the project. The company responsible for the generation or maintenance of the file or some parts of the file is determined by a <TEAM-MEMBER-REF> within <ADMIN-DATA> . In simple cases there is only one company.
Example
Formal Description
Within context of: | REPORT-HEAD
Is context for: | COMPANY
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.48. COMPANY

Description
Use <COMPANY> , to describe the company, its role and its members.
Example
Formal Description
Within context of: | COMPANIES
Is context for: | LONG-NAME, SHORT-NAME, ROLES, TEAM-MEMBERS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[ROLE] optional | SGML string (NMTOKEN) |  | Select MANUFACTURER, if the company participating in the project is a manufacturer/partner. Select SUPPLIER, if this is the function of the company participating in the project.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-CHILD-TYPE] fixed value | String (CDATA) | LONG-NAME:SELECTION | Fixed Child Type. Warning: This attribute is included in the DTD for compatibility with older versions and should not be used for any new implementations. It may be removed in future versions of the DTD. The attribute contains information stating which child elements of the element carrying this attribute, should be checked by an semantic checker.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | TEAM-MEMBER | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


2.49. COMPANY-DOC-INFO

Description
Use <COMPANY-DOC-INFO> , to generate document information on the companies participating in the project.
Example
Formal Description
Within context of: | COMPANY-DOC-INFOS
Is context for: | COMPANY-REF, DOC-LABEL, TEAM-MEMBER-REF, SDGS
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.50. COMPANY-DOC-INFOS

Description
Use <COMPANY-DOC-INFOS> , to generate a summary of the document information on the companies participating in the project.
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | COMPANY-DOC-INFO
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.51. COMPANY-REF

Description
Use <COMPANY-REF> , to refer to the company for which you wish to generate corporate-specific document information.
Example
Formal Description
Within context of: | COMPANY-DOC-INFO, COMPANY-REVISION-INFO
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF) used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.52. COMPANY-REVISION-INFO

Description
Use <COMPANY-REVISION-INFO> , to generate information on document version within the respective company.
Example
Formal Description
Within context of: | COMPANY-REVISION-INFOS
Is context for: | COMPANY-REF, REVISION-LABEL, REVISION-LABEL-P1, REVISION-LABEL-P2, STATE
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.53. COMPANY-REVISION-INFOS

Description
Use <COMPANY-REVISION-INFOS> , to generate a summary of the information on document version within a company.
Example
Formal Description
Within context of: | DOC-REVISION
Is context for: | COMPANY-REVISION-INFO
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.54. COND

Description
Use <COND> , to enter marginal conditions for which parameter values are valid.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | P
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.55. DATE

Description
<DATE> is used to capture a time stamp. It must match to one of the following syntaxes based on [Representation of dates and times;ISO-8601;]. In multilingual DTDs <DATE> is also multilingual.
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Example
<DATE>2001-03-20T09:00:00</DATE>
Formal Description
Within context of: | CHG-ACTION, CHG-OBJECT-REVISION, CHG-REQUEST, DOC-REVISION
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.56. DATE-1

Description
Use <DATE-1> , to enter the validity date of a standard document, or the creation date of an external document.
The element is like <DATE> but is never handled multilingual.
<DATE> is used to capture a time stamp. It must match to one of the following syntaxes based on [Representation of dates and times;ISO-8601;]:
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Example
Formal Description
Within context of: | STD, XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.57. DEF

Description
Use <DEF> , to enter a paragraph within the definition list for describing the title.
Example
Formal Description
Within context of: | DEF-ITEM
Is context for: | P
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.58. DEF-ITEM

Description
Use <DEF-ITEM> , to enter the title of an enumeration element in the definition list.
Example
Formal Description
Within context of: | DEF-LIST
Is context for: | LONG-NAME, SHORT-NAME, DEF
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
DEF-ITEM
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.59. DEF-LIST

Description
Use <DEF-LIST> , to create a definition list, where the marginal notes can be referenced.
Example
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, ENTRY, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, TOPIC-1, TOPIC-2
Is context for: | DEF-ITEM
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.60. DEPARTMENT

Description
Use <DEPARTMENT> , to enter the department of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.61. DESC

Description
<DESC> represents a general but brief description of the object in question.
Example
<DESC> This calibration is a gain
                                                that is used for the transition period between crank to run. It should be set
                                                between 1000 and 1500.
                </DESC>
Formal Description
Within context of: | CHG-ACTION, CHG-OBJECT, CHG-OBJECT-REVISION, FIGURE, PRM, SDG-CAPTION, SYN-ARGUMENT, SYN-CAPTION, SYN-EXAMPLE, SYN-RETURN-VALUE, SYN-SEMANTICS
Is context for: | L-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.62. DOC-LABEL

Description
Use <DOC-LABEL> , to enter the title of the document, or a label for the part of the document for which you wish to generate administrative data.
Example
Formal Description
Within context of: | COMPANY-DOC-INFO
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.63. DOC-REVISION

Description
Use <DOC-REVISION> , to generate information on the corresponding document version.
Example
Formal Description
Within context of: | DOC-REVISIONS
Is context for: | COMPANY-REVISION-INFOS, REVISION-LABEL, REVISION-LABEL-P1, REVISION-LABEL-P2, STATE, ISSUED-BY, TEAM-MEMBER-REF, DATE, MODIFICATIONS
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.64. DOC-REVISIONS

Description
<DOC-REVISIONS> is a container for the entire change-history for an object containing <ADMIN-DATA> and <DOC-REVISIONS>. Although the sequence of changes can be determined by sorting <DOC-REVISIONS> according to <DOC-REVISION>/ <DATE>, it is recommended that the most recent <DOC-REVISION> is the first child of <DOC-REVISIONS> .
Example
For an example, see 2.5. ADMIN-DATA .
Formal Description
Within context of: | ADMIN-DATA
Is context for: | DOC-REVISION
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.65. E

Description
Use <E> , to highlight sections of text within a paragraph element.
Example
Formal Description
Within context of: | FT, L-1, L-2, L-4, L-5, LONG-NAME-1
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • BOLD
  • ITALIC
  • BOLDITALIC
  • PLAIN
You can highlight text using BOLD or ITALIC to alter its appearance.
[COLOR]
optional
String (CDATA)
Color value, specified in SRBG A Color value can either be a hexadecimal value (prefixed with #) or one of the predefined color names, e.g "black", "dodgerblue" or "indianred". The color names are case-insensitive.
[FONT]
optional
Value selection (NAMEDTOKENGROUP)
  • MONO
  • DEFAULT
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.66. EMAIL

Description
Use <EMAIL> , to enter the email address of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.67. ENTRY

Description
Use <ENTRY> , that contains a paragraph element to display the contents of a table cell.
Example
Formal Description
Within context of: | ROW
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Type
Values / Default
Notes
[MOREROWS]
has default value
SGML string (NMTOKEN)
0
Modify the attribute to merge the appropriate <ENTRY> cell with the cells belonging to the subsequent rows. Enter 0 if you do not wish to merge any cells. Enter 1 to merge a cell with a cell in the next row. Enter a numeric value n to merge a cell with cells in n subsequent rows.
[ROTATE]
has default value
SGML string (NMTOKEN)
0
Enter the angle by which the contents of a cell should be rotated.
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • MIDDLE
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.
[ALIGN]
optional
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
optional
String (CDATA)
If [ALIGN]="CHAR", this specifies the alignment sign e.g. "bzlw", as a decimal point separator from an existing value of [CHAR] . The sign cannot be a SDATA entity.
[CHAROFF]
optional
SGML string (NMTOKEN)
If [ALIGN]="CHAR", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <ENTRY>, alignment is always horizontal right. The default value is taken from <COLSPEC> or <SPANSPEC> .
[COLNAME]
optional
SGML string (NMTOKEN)
Now, specify an identification name for the column that has been modified, e.g. column1 for the first one.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[NAMEEND]
optional
SGML string (NMTOKEN)
Identification number of the final column included in the merge.
[NAMEST]
optional
SGML string (NMTOKEN)
Identification number of the first column to be merged.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[SPANNAME]
optional
SGML string (NMTOKEN)
Identification name of a specified column merge.
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.68. FAX

Description
Use <FAX> , to enter the fax number of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.69. FIGURE

Description
Use <FIGURE> , to integrate graphics into a document.
Example
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, ENTRY, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, TOPIC-1, TOPIC-2
Is context for: | FIGURE-CAPTION, L-GRAPHIC, MAP, VERBATIM, DESC
Name
Type
Values / Default
Notes
[FLOAT]
optional
Value selection (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Permits a check, in the case of a <FIGURE> that cannot be broken up, to determine whether the <FIGURE> can be shifted elsewhere, so that the page can be used to a greater advantage (compare to flat at TeX).
[FRAME]
optional
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • TOPBOT
  • ALL
  • SIDES
  • NONE
TOP - Border at the top of the picture
BOTTOM - Border at the bottom of the figure
TOPBOT - Borders at the top and bottom of the figure
ALL - Borders all around the figure
SIDES - Borders at the sides of the figure
NONE - No borders around the figure
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
KEEP: ensures that the graphic and the element preceding it are not separated. NO-KEEP separates the two elements.
[PGWIDE]
optional
Value selection (NAMEDTOKENGROUP)
  • PGWIDE
  • NO-PGWIDE
PGWIDE: enables the expansion of the diagram to fit across the entire page. NO-PGWIDIE suppresses expansion across the page if, for example, a fixed margin has been given.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.70. FIGURE-CAPTION

Description
This element specifies the title of an illustration.
Example
Formal Description
Within context of: | FIGURE
Is context for: | LONG-NAME, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | FIGURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.71. FORMATTER-CTRL

Description
This element contains instructions to be formatted that can be freely specified, such as the scope of the context in which <FORMATTER-CTRL> is located. Here, the attribute [SI] can carry on further useful information obtained through the formatting process.
Example
Formal Description
Within context of: | FORMATTER-CTRLS
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[TARGET-SYSTEM] optional | String (CDATA) | This attribute can specify a target system which is valid for the current setting. If the attribute is absent, it is valid for all target systems. The target systems determine how this attribute should be interpreted. For example, the view control on creation of a help file could proceede in the following way: if there is a formatter-ctrl, si="view" target-system="htmlhelp", this will be used. If there is no specific view, but a formatter-ctrl si="view", without a target system specification, then this is used.
[VIEW] optional | String (CDATA) |


2.72. FORMATTER-CTRLS

Description
Container-Element for <FORMATTER-CTRL> .
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | FORMATTER-CTRL
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.73. FORMULA

Description
Use <FORMULA> , to enter a formula in a document.
Example
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, ENTRY, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, TOPIC-1, TOPIC-2
Is context for: | FORMULA-CAPTION, L-GRAPHIC, MAP, VERBATIM, TEX-MATH, C-CODE, GENERIC-MATH
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
KEEP: ensures that the formula and the element preceding it are not separated. NO-KEEP separates the two elements.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.74. FORMULA-CAPTION

Description
This element specifies the identification or heading of a formula.
Example
Formal Description
Within context of: | FORMULA
Is context for: | LONG-NAME, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | FORMULA | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.75. FT

Description
Use <FT> , to create a footnote.
Example
<FT>This text appears as a footnote</FT>
Formal Description
Within context of: | L-1, L-2
Is context for: | Text, TT, E
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.76. GENERIC-MATH

Description
Use <GENERIC-MATH> to insert semantic and mathematical descriptions which are processed by a math-processor.
Example
Formal Description
Within context of: | FORMULA
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.77. GRAPHIC

Description
Use <GRAPHIC> , to integrate an already existing graphic in the context elements.
Example
Formal Description
Within context of: | L-GRAPHIC
Is context for: | Text
Name
Type
Values / Default
Notes
[EDITFIT]
has default value
Value selection (NAMEDTOKENGROUP)
  • AS-IS
  • ROTATE-90-CW
  • ROTATE-90-CCW
  • ROTATE-180
  • FIT-TO-TEXT
  • FIT-TO-PAGE
  • LIMIT-TO-TEXT
  • LIMIT-TO-PAGE
  • ROTATE-90-CW-FIT-TO-TEXT
  • ROTATE-90-CCW-FIT-TO-TEXT
  • ROTATE-180-LIMIT-TO-TEXT
  • ROTATE-90-CW-LIMIT-TO-PAGE
  • ROTATE-90-CCW-LIMIT-TO-PAGE
  • ROTATE-180-LIMIT-TO-PAGE
  • 0
  • 1
  • 2
  • 3
FIT properties of the graphic in edit mode.
[FIT]
has default value
Value selection (NAMEDTOKENGROUP)
  • AS-IS
  • ROTATE-90-CW
  • ROTATE-90-CCW
  • ROTATE-180
  • FIT-TO-TEXT
  • FIT-TO-PAGE
  • LIMIT-TO-TEXT
  • LIMIT-TO-PAGE
  • ROTATE-90-CW-FIT-TO-TEXT
  • ROTATE-90-CCW-FIT-TO-TEXT
  • ROTATE-180-LIMIT-TO-TEXT
  • ROTATE-90-CW-LIMIT-TO-PAGE
  • ROTATE-90-CCW-LIMIT-TO-PAGE
  • ROTATE-180-LIMIT-TO-PAGE
  • 0
  • 1
  • 2
  • 3
Modify the attribute [FIT], to determine the way in which the graphic should be inserted. Enter the attribute value 0 , to insert a graphic in its original dimensions. The graphic is adapted, if it is too big for the space for which it was intended.
[HTML-FIT]
has default value
Value selection (NAMEDTOKENGROUP)
  • AS-IS
  • ROTATE-90-CW
  • ROTATE-90-CCW
  • ROTATE-180
  • FIT-TO-TEXT
  • FIT-TO-PAGE
  • LIMIT-TO-TEXT
  • LIMIT-TO-PAGE
  • ROTATE-90-CW-FIT-TO-TEXT
  • ROTATE-90-CCW-FIT-TO-TEXT
  • ROTATE-180-LIMIT-TO-TEXT
  • ROTATE-90-CW-LIMIT-TO-PAGE
  • ROTATE-90-CCW-LIMIT-TO-PAGE
  • ROTATE-180-LIMIT-TO-PAGE
  • 0
  • 1
  • 2
  • 3
Determines whether the graphic should be adapted to fit the dimensions of the window.
[CATEGORY]
optional
Value selection (NAMEDTOKENGROUP)
  • BARCODE
  • CONCEPTUAL
  • ENGINEERING
  • FLOWCHART
  • GRAPH
  • LOGO
  • SCHEMATIC
  • WAVEFORM
Here, you can enter the category of the graphic. This can be used to generate a list of graphics from specific categories.
[EDIT-HEIGHT]
optional
String (CDATA)
Height of the graphic in editor
[EDIT-WIDTH]
optional
String (CDATA)
Width of the graphic in editor
[EDITSCALE]
optional
String (CDATA)
Scale of the graphic in edit mode.
[FILENAME]
optional
String (CDATA)
Here, you should enter the file name under which the system for reproduction can call the graphic.
[HEIGHT]
optional
String (CDATA)
In this attribute, the height of the graphic can be altered.
[HTML-HEIGHT]
optional
String (CDATA)
Height of the graphic displayed online in html and htmlhelp.
[HTML-SCALE]
optional
String (CDATA)
Scale of the graphic when displayed in html and htmlhelp.
[HTML-WIDTH]
optional
String (CDATA)
Width of the graphic displayed online in html and htmlhelp.
[NOTATION]
optional
String (CDATA)
Now the format of the graphic file must be specified, e.g. EPS.
[S]
optional
String (CDATA)
[SCALE]
optional
String (CDATA)
In this element the dimensions of the graphic can be altered proportionally.
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[WIDTH]
optional
String (CDATA)
In this attribute, the width of the graphic can be altered.


2.78. HOMEPAGE

Description
Use <HOMEPAGE> , to enter the company email address of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.79. IE

Description
Use <IE> to create an index that is to appear in the index directory.
Example
Formal Description
Within context of: | L-1, L-2, L-4, LONG-NAME-1
Is context for: | Text, SUP, SUB
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[TYPE] optional | String (CDATA) | Indicates a type of the respective element.
[VIEW] optional | String (CDATA) |


2.80. INDENT-SAMPLE

Description
Use <INDENT-SAMPLE> to set the amount of indentation for the parent object.
Example
The following example sets an indentation of one unit.
<INDENT-SAMPLE>X</INDENT-SAMLPE>
Formal Description
Within context of: | LABELED-LIST
Is context for: | L-2
Name
Type
Values / Default
Notes
[ITEM-LABEL-POS]
has default value
Value selection (NAMEDTOKENGROUP)
  • NO-NEWLINE
  • NEWLINE
  • NEWLINE-IF-NECESSARY
NO-NEWLINE - line break inside the first column. NEWLINE - no line break inside the first column. The description regarding designation begins in the second row. NEWLINE-IF-NECESSARY - no line break inside the first column. If the marginal notes designation is longer than in the <INDENT-SAMPLE> , the description begins in the second row. Otherwise it begins in the first.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.81. INTRODUCTION

Description
<INTRODUCTION> provides a general introduction to the object in question.
  • Use <P> to enable the processing systems to perform a word wrapping.
  • Use <VERBATIM> if white-spaces are significant.
Example
 <INTRODUCTION>
                   <P>This File is used to illustrate, how CDF can be implentend according
                      to ASAM-MCD-2MC 2.0 resp. MSRSW.DTD 2.2.0 </P>
                </INTRODUCTION>
Formal Description
Within context of: | CHAPTER, CHG-CHAPTER
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2, TOPIC-2, MSR-QUERY-TOPIC-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.82. ISSUED-BY

Description
This element contains the name of the person who initiated the document revision. If the initiator cannot be referenced as <TEAM-MEMBER> in the current document his name can be given in this element.
Example
Formal Description
Within context of: | DOC-REVISION
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.83. ITEM

Description
Use <ITEM> to create entries in a <LIST>.
Example
Formal Description
Within context of: | LIST
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.84. ITEM-LABEL

Description
Use <ITEM-LABEL> to enter the label for the parent object.
Example
Formal Description
Within context of: | LABELED-ITEM, SYN-ARGUMENT, SYN-OBJECT
Is context for: | L-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.85. L-1

Description
Example
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P
Is context for: | Text, TT, BR, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT
Name | Type | Notes
[L] required | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.86. L-10

Description
Example
Formal Description
Within context of: | C-CODE, DATE, DOC-LABEL, GENERIC-MATH, ISSUED-BY, REVISION-LABEL, ROLE, STATE, TEX-MATH, USED-LANGUAGES
Is context for: | Text
Name | Type | Notes
[L] required | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.87. L-2

Description
Example
Formal Description
Within context of: | INDENT-SAMPLE, ITEM-LABEL, MAIN-TITLE, OVERALL-TITLE, REASON, SUB-TITLE
Is context for: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name | Type | Notes
[L] required | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.88. L-3

Description
Example
Formal Description
Within context of: | TEXT, UNIT
Is context for: | Text, SUP, SUB
Name | Type | Notes
[L] required | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.89. L-4

Description
Example
Formal Description
Within context of: | LABEL, LONG-NAME
Is context for: | Text, TT, E, SUP, SUB, IE
Name | Type | Notes
[L] required | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.90. L-5

Description
Example
Formal Description
Within context of: | VERBATIM
Is context for: | Text, E, XREF, BR
Name | Type | Notes
[L] required | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.91. L-GRAPHIC

Description
Example
Formal Description
Within context of: | FIGURE, FORMULA
Is context for: | GRAPHIC, MAP
Name | Type | Notes
[L] required | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.92. LABEL

Description
<LABEL> is used as a long designator (similar to <LONG-NAME> ) for objects which cannot be referenced. In this case it is the name of the corresponding project.
Example
Refer to 2.128. NOTE for an example, where <LABEL> is the name of the corresponding project.
Formal Description
Within context of: | MATCHING-DCI, NOTE, PRMS
Is context for: | L-4
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.93. LABELED-ITEM

Description
Use <LABELED-ITEM> to create an entry in a labeled list. The list can be nested by creating a new <LABELED-LIST> within the <LABELED-ITEM> .
Example
Formal Description
Within context of: | LABELED-LIST
Is context for: | ITEM-LABEL, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.94. LABELED-LIST

Description
Use <LABELED-LIST> to create a list with labels that can be nested.
Example
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, ENTRY, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, TOPIC-1, TOPIC-2
Is context for: | INDENT-SAMPLE, LABELED-ITEM
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.95. LANGUAGE

Description
<LANGUAGE> represents the human language used within the file. Its primary use is to prompt the tools to switch to an appropriate language.
This element is in accordance with the ISO 639-1 two letter language codes ( Codes for the Representation of Names of Languages ). The most frequently used codes are given in Most common language codes (alphabetical) :
Most common language codes (alphabetical)
Code | Language
de | German
en | English
es | Spanish
fr | French
it | Italian
jp | Japanese
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.96. LIST

Description
Use <LIST> , to create a numbered or unnumbered list. The list can be nested by adding a new list inside the <ITEM> element.
Example
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, ENTRY, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, TOPIC-1, TOPIC-2
Is context for: | ITEM
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • UNNUMBER
  • NUMBER
UNNUMBER - enumeration without numbering NUMBER - numbered enumeration
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.97. LOCS

Description
Use <LOCS> to generate references to external documents.
Example
Formal Description
Within context of: | MSRREP
Is context for: | NAMELOC
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.98. LONG-NAME

Description
Use <LONG-NAME> to create a comprehensive name for the context element.
Example
<LONG-NAME>Variable 1 that keeps the cabin preassure</LONG-NAME>
Formal Description
Within context of: | CHAPTER, CHG-CHAPTER, CHG-OBJECT, CHG-OBJECT-REVISION, CHG-REQUEST, COMPANY, DEF-ITEM, FIGURE-CAPTION, FORMULA-CAPTION, NAMELOC, PRM, SDG-CAPTION, SYN-CAPTION, TABLE-CAPTION, TEAM-MEMBER, TOPIC-1, TOPIC-2
Is context for: | L-4
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.99. LONG-NAME-1

Description
Use <LONG-NAME-1> to create a comprehensive name for the context element
Example
Formal Description
Within context of: | STD, XDOC, XFILE, XREF-TARGET
Is context for: | Text, TT, E, SUP, SUB, IE
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.100. MAIN-TITLE

Description
Example
Formal Description
Within context of: | REPORT-SUBJECT
Is context for: | L-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.101. MAP

Description
Image maps enable authors to specify regions of an image or object and assign a specific action to each region (e.g., retrieve a document, run a program, etc.) When the region is activated by the user, the action is executed.
Example
Formal Description
Within context of: | FIGURE, FORMULA, L-GRAPHIC
Is context for: | AREA
Name | Type | Notes
[CLASS] optional | String (CDATA) | Blank separated list of classes
[ID] optional | ID (ID) | Unambiguous identifier of the element within the document.
[NAME] optional | SGML string (NMTOKEN) | This attribute assigns a name to the image map in the MAP element. This name can be used to be referenced in an HTML image through the attribute USEMAP. Although this is not actually necessary in the MSR model, it was inserted in order to support the MAPs which were created for HTML.
[ONCLICK] optional | String (CDATA) | The ONCLICK-Event occurs, if the current element is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONDBLCLICK] optional | String (CDATA) | The ONDBLCLICK-Event occurs, if the current Event is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONKEYDOWN] optional | String (CDATA) | The ONKEYDOWN-Event occurs, if a button on the current element is pressed down. A script can be stored in this attribute to be performed in the Event.
[ONKEYPRESS] optional | String (CDATA) | The ONKEYPRESS-Event occurs, if a button on the current element is pressed down and released. A script can be stored in this attribute to be performed in the Event.
[ONKEYUP] optional | String (CDATA) | The ONKEYUP-Event occurs, if a button on the current element is released. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEDOWN] optional | String (CDATA) | The ONMOUSEDOWN-Event occurs, if the mouse button used for clicking is held down on the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEMOVE] optional | String (CDATA) | The ONMOUSEMOVE-Event occurs, if the mouse pointer is moved on the current element (i.e. it is located on the current element). A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOUT] optional | String (CDATA) | The ONMOUSEOUT-Event occurs, if the mouse pointer is moved from the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOVER] optional | String (CDATA) | The ONMOUSEOVER-Event occurs, if the mouse pointer is moved to the current element from another location outside it. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEUP] optional | String (CDATA) | The ONMOUSEUP-Event occurs if the mouse button used for clicking is released on the current element. A script can be stored in this attribute to be performed in the Event.
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[STYLE] optional | String (CDATA) | Information on the associated style
[T] optional | String (CDATA) |
[TITLE] optional | String (CDATA) | Title information of the <MAP> -element
[VIEW] optional | String (CDATA) |


2.102. MATCHING-DCI

Description
<MATCHING-DCI> represents a reference to a DCI instance (Document Content Information) to which the current file should match. The official identification of the DCI is denoted by <URL> which points to the DCI file. The other elements are given to provide information.
Example
Formal Description
Within context of: | MATCHING-DCIS
Is context for: | LABEL, SHORT-LABEL, URL, REMARK
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.103. MATCHING-DCIS

Description
<MATCHING-DCIS> represents all Document Content Information specifications to which the current file should comply. As there may be multiple DCI instances, the current file should match all of them. Nevertheless, the check is only requested according to the case currently in use.
Especially in the case of the CDF, a CDF processor is obliged to check if the CDF-DCI is mentioned in <MATCHING-DCIS> .
Example
In the following example, the current file would match CDF as well as PACO which would support more of the features in MSRSW.DTD .
<MATCHING-DCIS>
                   <MATCHING-DCI>
                      <LABEL>Parameter Contents File</LABEL>
                      <SHORT-LABEL>PACO2.0</SHORT-LABEL>
                      <URL>http://www.msr-wg.de/dcis/paco.dci.xml</URL>
                   </MATCHING-DCI>
                   <MATCHING-DCI>
                      <LABEL>Calibration Data File Specification</LABEL>
                      <SHORT-LABEL>CDF</SHORT-LABEL>
                      <URL>http://www.asam.net/dcis/cdf.dci.xml</URL>
                   </MATCHING-DCI>
                </MATCHING-DCIS>
Formal Description
Within context of: | MSRREP
Is context for: | MATCHING-DCI
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.104. MAX

Description
Use <MAX> to enter the maximum values of a parameter in a table of parameters.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.105. MIN

Description
Use <MIN> to enter the minimum values of a parameter in a table of parameters.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.106. MODIFICATION

Description
Use <MODIFICATION> to record what has changed in a document in comparison to its predecessor.
Example
Formal Description
Within context of: | MODIFICATIONS
Is context for: | CHANGE, REASON
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • CONTENT-RELATED
  • DOC-RELATED
DOC-RELATED - document-specific changes have necessitated a new document version. CONTENT-RELATED - product-specific changes have necessitated a new document version.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.107. MODIFICATIONS

Description
<MODIFICATIONS> contains the changes in a document in comparison to its predecessor.
Example
Formal Description
Within context of: | DOC-REVISION
Is context for: | MODIFICATION
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.108. MSR-PROCESSING-LOG

Description
This element is a placeholder in which tools responsible for the automatic processing of the instance can store processing execution information (log information). It is advisable to create an individual chapter ( <CHAPTER> ) for every process executed. The most recent chapter should come first (sorting according to date).
Example
<MSR-PROCESSING-LOG>
                   <CHAPTER>
                      <LONG-NAME>MSR-Query 2.10.2001</LONG-NAME>
                      <SHORT-NAME>msrquery.2001.10.02-1</SHORT-NAME>
                      <VERBATIM>MSR-Query processor Version 0.99 run at 2.10.2001 reading file
                                c:\examples\myexample.sgm warning: duplicate ID found ("hugo") error: query
                                "replacechapters" not implemented 20 queries processed 1 warning 1
                                error
                      </VERBATIM>
                   </CHAPTER>
                   <CHAPTER>
                      <LONG-NAME>MSR-Query 1.10.2001</LONG-NAME>
                      <SHORT-NAME>msrquery.2001.10.01-1</SHORT-NAME>
                      <VERBATIM>MSR-Query processor Version 0.99 run at 1.10.2001 reading file
                                c:\examples\myexample.sgm warning: duplicate ID found ("hugo") error: query
                                "replacechapters" not implemented 20 queries processed 1 warning 1
                   error
                      </VERBATIM>
                   </CHAPTER>
                </MSR-PROCESSING-LOG>
Formal Description
Within context of: | MSRREP
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.109. MSR-QUERY-ARG

Description
This element specifies an argument within a so-called MSR-QUERY which is named in the sister element <MSR-QUERY-NAME> .
Example
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text, XREF
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.110. MSR-QUERY-CHAPTER

Description
This element contains a chapter generated through an external query or a chapter generated in an external program (in <MSR-QUERY-RESULT-CHAPTER>), as well as the data necessary to enable a conclusion to be drawn as to the origins of a chapter (in <MSR-QUERY-PROPS> ).
Example
Formal Description
Within context of: | CHAPTER, MSR-PROCESSING-LOG, REPORT-BODY, REPORT-HEAD, REPORT-REAR
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-CHAPTER
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.111. MSR-QUERY-NAME

Description
This element specifies the name of the MSR-QUERY triggered.
Example
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.112. MSR-QUERY-P-1

Description
This element contains the arguments <MSR-QUERY-PROPS>. In addition, it may also contain result elements in text form, embedded in <MSR-QUERY-RESULT-P-1>, which correspond to a MSR-QUERY , generated either by an external program or an external query, for the purpose of integrating the element into an MSRSW instance.
Example
Formal Description
Within context of: | ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, MSR-PROCESSING-LOG, TOPIC-1
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-P-1
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.113. MSR-QUERY-P-2

Description
This element contains the arguments <MSR-QUERY-PROPS>. In addition, it may also contain result elements in text form, embedded in <MSR-QUERY-RESULT-P-2>, which correspond to a MSR-QUERY , generated either by an external program or an external query, for the purpose of integrating the element into an MSRSW instance.
Example
Formal Description
Within context of: | ABSTRACT, INTRODUCTION, TOPIC-2
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-P-2
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.114. MSR-QUERY-PROPS

Description
This element specifies the characteristics and arguments of a MSR-QUERY, that is, the name <MSR-QUERY-NAME>, the arguments <MSR-QUERY-ARG> and if required, the comment <COMMENT> .
Example
Formal Description
Within context of: | MSR-QUERY-CHAPTER, MSR-QUERY-P-1, MSR-QUERY-P-2, MSR-QUERY-TEXT, MSR-QUERY-TOPIC-1, MSR-QUERY-TOPIC-2
Is context for: | MSR-QUERY-NAME, MSR-QUERY-ARG, COMMENT
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.115. MSR-QUERY-RESULT-CHAPTER

Description
This element contains the result chapter of a MSR-QUERY , which was generated by an external program or an external query, so that it could be integrated into an MSRSW instance.
Example
Formal Description
Within context of: | MSR-QUERY-CHAPTER
Is context for: | CHAPTER
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.116. MSR-QUERY-RESULT-P-1

Description
This element contains the result element of a MSR-QUERY in text form, which was generated by an external program or an external query, so that it could be integrated into an MSRSW instance. Unlike <MSR-QUERY-RESULT-P-2>, <MSR-QUERY-RESULT-P-1> may still contain <PRMS> elements.
Example
Formal Description
Within context of: | MSR-QUERY-P-1
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, PRMS
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.117. MSR-QUERY-RESULT-P-2

Description
This element contains the result element of a MSR-QUERY in text form, which was generated by an external program or an external query, so that it could be integrated into an MSRSW instance. Unlike <MSR-QUERY-RESULT-P-1>, <MSR-QUERY-RESULT-P-2> may contain no <PRMS> elements.
Example
Formal Description
Within context of: | MSR-QUERY-P-2
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.118. MSR-QUERY-RESULT-TEXT

Description
This element contains the textual description within <MSR-QUERY-TEXT>, generated by a MSR-QUERY , which encompasses no further sub-paragraphs.
Example
Formal Description
Within context of: | MSR-QUERY-TEXT
Is context for: | L-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.119. MSR-QUERY-RESULT-TOPIC-1

Description
This element contains the result of a <TOPIC-1> element generated from an external MSR-QUERY .
Example
Formal Description
Within context of: | MSR-QUERY-TOPIC-1
Is context for: | TOPIC-1
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.120. MSR-QUERY-RESULT-TOPIC-2

Description
This element contains the result of a <TOPIC-2> element generated from an external MSR-QUERY .
Example
Formal Description
Within context of: | MSR-QUERY-TOPIC-2
Is context for: | TOPIC-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.121. MSR-QUERY-TEXT

Description
This element contains a MSR-QUERY specified more accurately in the subelement <MSR-QUERY-PROPS>, as well as the textual description generated as a result of it within the subelement <MSR-QUERY-TEXT> , which contains no further subparagraphs.
Example
Formal Description
Within context of: | L-1, L-2
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TEXT
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.122. MSR-QUERY-TOPIC-1

Description
This element contains a generated TOPIC-1 element with a result in <MSR-QUERY-RESULT-TOPIC-1>. This is from an external MSR-QUERY which is defined more accurately in <MSR-QUERY-PROPS> .
Example
Formal Description
Within context of: | CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, MSR-PROCESSING-LOG
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TOPIC-1
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.123. MSR-QUERY-TOPIC-2

Description
This element contains a generated TOPIC-2 element with a result in <MSR-QUERY-RESULT-TOPIC-2>. This is from an external MSR-QUERY which is defined more accurately in <MSR-QUERY-PROPS> .
Example
Formal Description
Within context of: | ABSTRACT, INTRODUCTION
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TOPIC-2
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.124. MSRREP

Description
Example
Formal Description
Within context of: | Root
Is context for: | SHORT-NAME, CATEGORY, REPORT-HEAD, ADMIN-DATA, REPORT-BODY, REPORT-REAR, SPECIAL-DATA, MSR-PROCESSING-LOG, MATCHING-DCIS, LOCS
Name | Type | Values / Default | Notes
[PUBID] has default value | String (CDATA) | -//MSR//DTD MSR REPORT DTD:V2.2.2:XML:ML:MSRREP.DTD//EN |
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-BUILD] fixed value | String (CDATA) | 1005 |
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | CHAPTER CHG-OBJECT CHG-OBJECT-REVISION CHG-REQUEST COMPANY DEF-ITEM EXTERNAL FIGURE FORMULA PRM SDG STD SYNOPSIS TABLE TEAM-MEMBER TOPIC XDOC XFILE XREF-TARGET |
[F-PUBID] fixed value | String (CDATA) | -//MSR//DTD MSR REPORT DTD:V2.2.2:XML:ML:MSRREP.DTD//EN |
[HYTIME] fixed value | SGML string (NMTOKEN) | HYDOC |


2.125. NAMELOC

Description
Use <NAMELOC> to identify the external document of a cross-reference spanning more than one document, that is to be referenced.
Example
Formal Description
Within context of: | LOCS
Is context for: | LONG-NAME, SHORT-NAME, NMLIST
Name | Type | Values / Default | Notes
[EXT-ID-CLASS] optional | SGML string (NMTOKEN) |  | External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | EXTERNAL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYTIME] fixed value | SGML string (NMTOKEN) | NAMELOC | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables the use of a generic architectural form processor for link processing and transition.


2.126. NMLIST

Description
Use <NMLIST> to enter the name of an entity or element, to be referenced in an external document.
Example
Formal Description
Within context of: | NAMELOC
Is context for: | Text
Name
Type
Values / Default
Notes
[NAMETYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • ENTITY
  • ELEMENT
ENTITY - reference to an entity in an external document. ELEMENT - reference to an element in an external document.
[DOCORSUB]
optional
Entity (ENTITY)
SGML/XML document or sub-document, the prologue of which declares entities or elements that occur in NMLIST. Refer to [FUNCTION-REF] for an example.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[HYTIME]
fixed value
SGML string (NMTOKEN)
NMLIST
HYTIME is the standard attribute use to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.127. NOTATION

Description
This element indicates the data format of the external file in which the superordinated XFILE is located. The identifier itself must be arranged amongst the project participants. The contents of <NOTATION> are treated in a similar way to an SGML notation format.
Possible values are for example:
Notation | Meaning
EPS | Encapsulated Postscript
PDF | Portable Document Format
CDF2.0 | CDF2.0 Parameter Contents File in MSRSW3.0 structure
... | ...
Example
<P>Please refer to
                   <XFILE>
                      <LONG-NAME-1>Parameter Contents file</LONG-NAME-1>
                      <SHORT-NAME>0711cdf20</SHORT-NAME>
                      <URL>../cdfs/0711cdf20.xml</URL>
                      <NOTATION>CDF20</NOTATION>
                      <TOOL>DDCL</TOOL>
                      <TOOL-VERSION>1.3</TOOL-VERSION>
                   </XFILE>
                </P>
Formal Description
Within context of: | XFILE
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.128. NOTE

Description
Use <NOTE> to highlight particular safety or usage notes.
Example
<NOTE NOTE-TYPE="CAUTION">
    <LABEL>Layout of <TT TYPE="SGMLTAG">NOTE</TT></LABEL>
        <P>Layout of <TT TYPE="SGMLTAG">NOTE</TT> may vary on
        the type according to the value of the attribute <TT TYPE="SGML-ATTRIBUTE">NOTE-TYPE</TT>
        and the target display or print system.</P>
</NOTE>
The code example above is formatted in the following way:
Caution: Layout of <NOTE>
Layout of <NOTE> may vary on the type according to the value of the attribute [NOTE-TYPE] and the target display or print system.
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, ENTRY, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, TOPIC-1, TOPIC-2
Is context for: | LABEL, P
Name
Type
Values / Default
Notes
[NOTE-TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • CAUTION
  • HINT
  • TIP
  • INSTRUCTION
  • EXERCISE
  • OTHER
CAUTION - dangers involving instruments and personnel during operation. HINT - special operation features
TIP - measures to improve efficiency
INSTRUCTION - important instructions
EXERCISE - practical examples
OTHER - additional notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[USER-DEFINED-TYPE]
optional
String (CDATA)
Allows user-specific notes to be introduced.
[VIEW]
optional
String (CDATA)


2.129. NUMBER

Description
Use <NUMBER> to enter the version number of an external document that is referenced.
Example
Formal Description
Within context of: | XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.130. OVERALL-TITLE

Description
Example
Formal Description
Within context of: | REPORT-SUBJECT
Is context for: | L-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.131. P

Description
Use <P> to create a paragraph for continuous texts.
Example
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, COND, DEF, ENTRY, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NOTE, REMARK, SYN-FORMAT, SYN-INCLUDE, SYN-OBJECT, SYN-SEE-ALSO, TOPIC-1, TOPIC-2
Is context for: | L-1
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.132. PHONE

Description
Use <PHONE> to enter the telephone number of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.133. POSITION

Description
Use <POSITION> to enter references to the relevant positions of a standard.
Example
Formal Description
Within context of: | STD, XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.134. PRM

Description
Use <PRM> to create a parameter table
Example
Formal Description
Within context of: | PRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.135. PRM-CHAR

Description
Use <PRM-CHAR> to generate parameter values.
Example
Formal Description
Within context of: | PRM
Is context for: | COND, ABS, TOL, MIN, TYP, MAX, UNIT, TEXT, REMARK
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.136. PRMS

Description
Use <PRMS> to create a parameter table for a number of parameters.
Example
Formal Description
Within context of: | CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, TOPIC-1
Is context for: | LABEL, PRM
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.137. PUBLISHER

Description
Use <PUBLISHER> to enter the publisher of an external document that is being referenced.
Example
Formal Description
Within context of: | XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.138. REASON

Description
Use <REASON> to cite the reason for changes to the document version.
Example
Formal Description
Within context of: | MODIFICATION
Is context for: | L-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.139. REMARK

Description
<REMARK> is used for comments e.g. on the specific calibration state. There are two options:
  • Use <P> to enable the processing systems to perform a word wrapping.
  • Use <VERBATIM> if a white-space is significant.
Example
Formal Description
Within context of: | MATCHING-DCI, PRM-CHAR
Is context for: | P, VERBATIM
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.140. REPORT-BODY

Description
Example
Formal Description
Within context of: | MSRREP
Is context for: | CHAPTER, MSR-QUERY-CHAPTER, CHG-CHAPTER
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.141. REPORT-HEAD

Description
Example
Formal Description
Within context of: | MSRREP
Is context for: | REPORT-SUBJECT, ABSTRACT, COMPANIES, CHAPTER, MSR-QUERY-CHAPTER
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.142. REPORT-REAR

Description
Example
Formal Description
Within context of: | MSRREP
Is context for: | CHAPTER, MSR-QUERY-CHAPTER
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.143. REPORT-SUBJECT

Description
Example
Formal Description
Within context of: | REPORT-HEAD
Is context for: | OVERALL-TITLE, MAIN-TITLE, SUB-TITLE
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.144. REVISION-LABEL

Description
Use <REVISION-LABEL>, to enter the version number of the document, or the document section to which administrative is applied.. The syntax is free and refers to the configuration management plan respectively the version management tool being used.
Example
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.145. REVISION-LABEL-P1

Description
Use <REVISION-LABEL-P1>, to enter the version number of the first predecessor of the document, or the document section to which administrative is applied.. The syntax is free and refers to the configuration management plan respectively the version management tool being used. This element is used, if the document or document section is the result of a merge process in which two branches are merged in to one new revision.
Example
<REVISION-LABEL>1.4</REVISION-LABEL>
                <REVISION-LABEL-P1>1.2.1.3</REVISION-LABEL-P1>
                <REVISION-LABEL-P2>1.3.1.4</REViSION-LABEL-P2>
This example shows a scenario where the current revision 1.4 is produced by merging 1.3.1.4 into 1.2.1.3
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.146. REVISION-LABEL-P2

Description
Use <REVISION-LABEL-P1>, to enter the version number of the second predecessor of the document, or the document section to which administrative is applied.. The syntax is free and refers to the configuration management plan respectively the version management tool being used. This element is used, if the document or document section is the result of a merge process in which two branches are merged in to one new revision.
Example
<REVISION-LABEL>1.4</REVISION-LABEL>
                <REVISION-LABEL-P1>1.2.1.3</REVISION-LABEL-P1>
                <REVISION-LABEL-P2>1.3.1.4</REViSION-LABEL-P2>
This example shows a scenario where current revision 1.4 is produced by merging 1.3.1.4 into 1.2.1.3
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.147. ROLE

Description
<ROLE> denotes one particular role adopted by the team member within the current project. Roles include "Author", "Calibration engineer", "Supporter", "Quality assurance".
Example
Formal Description
Within context of: | ROLES
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.148. ROLES

Description
<ROLES> is a wrapper containing all the roles attributed to one particular team member involved in the project.
Example
Formal Description
Within context of: | COMPANY, TEAM-MEMBER
Is context for: | ROLE
Name | Type | Values / Default | Notes
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-CHILD-TYPE] fixed value | String (CDATA) | ROLE:SELECTION | Fixed Child Type. Warning: This attribute is included in the DTD for compatibility with older versions and should not be used for any new implementations. It may be removed in future versions of the DTD. The attribute contains information stating which child elements of the element carrying this attribute, should be checked by an semantic checker.


2.149. ROW

Description
Use <ROW> , to create a row in a table.
Example
Formal Description
Within context of: | TBODY, TFOOT, THEAD
Is context for: | ENTRY
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • MIDDLE
TOP - The contents of the row is aligned to the upper edge of the cell. BOTTOM - The contents of the row is aligned to the lower edge of the cell. MIDDLE - The contents of the row is centered to the vertical.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.150. SD

Description
This element is a "Special Data" element. By using this element it is possible to extend the dtd with a "new" element tag.
Example
If the element:
<BIG-NUMBER>1000</BIG-NUMBER>
is required but doesn't exist in the dtd it can be created with a <SD> element. It would then look like this:
<SD GID="BIG-NUMBER">1000</SD>
Formal Description
Within context of: | SDG
Is context for: | Text
Name | Type | Notes
[GID] required | String (CDATA) | Identification name of the new element
[ID-CLASS] optional | SGML string (NMTOKEN) |
[ID-REF] optional | ID reference (IDREF) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.151. SDG

Description
SDG ( Special Data Group) is a backdoor used to handle elements that has not yet been defined in a DTD. The <SDG> is a containder for one or several <SD> that defines new elements and carries the information. Special Data should only be used moderately since all elements should be defined in the dtd. Thereby should SDG be considered as a temporary sollution when elements are missing. If a <SDG-CAPTION> element is created along with a <SHORT-NAME> it is possible to reference the <SDG> structure via a <XREF>.
Example
If the element structure:
<MY-NUMBERS>
                  <BIG-NUMBER>1000</BIG-NUMBER>
                  <SMALL-NUMBER>1</SMALL-NUMBER>
                <MY-NUMBERS>
is required but doesn't exist in the dtd it can be created with a <SDG> and some <SD> elements. It would then look like this:
<SDG GID="MY-NUMBERS">
                  <SD GID="BIG-NUMBER">1000</SD>
                  <SD GID="SMALL-NUMBER">1</SD>
                </SDG>
Formal Description
Within context of: | SDG, SDGS, SPECIAL-DATA
Is context for: | SDG-CAPTION, SD, SDG
Name | Type | Notes
[GID] required | String (CDATA) | Identification name of the element group
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.152. SDG-CAPTION

Description
This enables a <SHORT-NAME> to be assigned to [ID] and enables a <LONG-NAME> to be assigned to a special data group <SDG> .
Example
Formal Description
Within context of: | SDG
Is context for: | LONG-NAME, SHORT-NAME, DESC
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SDG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.153. SDGS

Description
This is a container for one or several <SDG> (Special Data Group) elements.
Special data groups (SDGs) are a standard extension mechanism for harmonized objects; they are used to store data for that no other element exists of the data model in a structured way. It could be considerd as a "well formed island" which allows to carry specific data even if the DTD itself does not expllicitly supports it. this prevents a process designer or a user to entirely switch to another technology if information musst be transferred whichis not explicitly supported.
Example
Examples for the usage of SDGs within harmonized objects are the company specific documentation in COMPANY DOC INFO.This document defines the structure of SDGs but not their content.
The following example is taken from [ASAM MCD 2 Harmonized Data Objects, Version 1.0-RC2 ;]
<SDGS>
                  <SDG>
                     <SDG-CAPTION ID="SDGC_ValidPL" TI="G">
                        <SHORT-NAME>ValidPL</SHORT-NAME>
                        <LONG-NAME>Validity production line</LONG-NAME>
                        <DESC>establishes the relation between ECU and production line</DESC>
                     </SDG-CAPTION>
                     <SD SI="prodline">E46-M3</SD>
                     <SD SI="prodline">E39-M3</SD>
                     <SD SI="prodline">E39-M5</SD>
                  </SDG>
                  <SDG>
                    <SDG-CAPTION ID="SDGC_DiagInd" TI="D">
                       <SHORT-NAME>DiagInd</SHORT-NAME>
                       <LONG-NAME>Diagnosisindex</LONG-NAME>
                    </SDG-CAPTION>
                    <SD>0.7</SD>
                  </SDG>
                </SDGS>
Formal Description
Within context of: | COMPANY-DOC-INFO
Is context for: | SDG
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.154. SHORT-LABEL

Description
This element specifies a short name for the context element. This label cannot be referenced in the same way as a <SHORT-NAME> in connection with MSRSW (queries, external applications etc.).
Example
See 2.103. MATCHING-DCIS 2.103. MATCHING-DCIS .
Formal Description
Within context of: | MATCHING-DCI
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.155. SHORT-NAME

Description
Use <SHORT-NAME> to generate a short name for the context element, which enables it to be referenced .
Example
Formal Description
Within context of: | CHAPTER, CHG-CHAPTER, CHG-OBJECT, CHG-OBJECT-REVISION, CHG-REQUEST, COMPANY, DEF-ITEM, FIGURE-CAPTION, FORMULA-CAPTION, MSRREP, NAMELOC, PRM, SDG-CAPTION, STD, SYN-CAPTION, TABLE-CAPTION, TEAM-MEMBER, TOPIC-1, TOPIC-2, XDOC, XFILE, XREF-TARGET
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.156. SPANSPEC

Description
Use <SPANSPEC> to determine the identification data for a merging of columns.
Example
Formal Description
Within context of: | TGROUP
Has no contents. |
Name
Type
Values / Default
Notes
[NAMEEND]
required
SGML string (NMTOKEN)
Identification number of the final column to be merged.
[NAMEST]
required
SGML string (NMTOKEN)
Identification number of the first column to be merged.
[SPANNAME]
required
SGML string (NMTOKEN)
Identification name for the column merging specified
[ALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
optional
String (CDATA)
If [ALIGN]="CHAR", this specifies the alignment sign e.g. "bzlw", as a decimal point separator from an existing value of [CHAR] . The sign cannot be a SDATA entity.
[CHAROFF]
optional
SGML string (NMTOKEN)
If [ALIGN]="CHAR", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <ENTRY>, alignment is always horizontal right. The default value is taken from the <COLSPEC> element, which is located in the attribute [NAMEST] .
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.157. SPECIAL-DATA

Description
Container element for <SDG> .
Example
Formal Description
Within context of: | MSRREP
Is context for: | SDG
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.158. STATE

Description
<STATE> represents the current state of the current file according to the configuration management plan.
Example
<STATE>reviewed</STATE>
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.159. STATE-1

Description
Use <STATE-1> to enter the version and state of a standard or an external document.
Example
Formal Description
Within context of: | STD, XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.160. STD

Description
Use <STD> to reference external standards within a paragraph element.
Example
Formal Description
Within context of: | L-1
Is context for: | LONG-NAME-1, SHORT-NAME, SUBTITLE, STATE-1, DATE-1, URL, POSITION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | STD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.161. SUB

Description
Use <SUB> to display sections of text within a paragraph element, in a smaller font beneath the base line.
Example
Formal Description
Within context of: | ABS, IE, L-1, L-2, L-3, L-4, LONG-NAME-1, MAX, MIN, TOL, TYP
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.162. SUB-TITLE

Description
Example
Formal Description
Within context of: | REPORT-SUBJECT
Is context for: | L-2
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.163. SUBTITLE

Description
Use <SUBTITLE> to enter a sub-heading of an external standard.
Example
Formal Description
Within context of: | STD
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.164. SUP

Description
Use <SUP> to display sections of text within a paragraph element, in a smaller font above the base line.
Example
Formal Description
Within context of: | ABS, IE, L-1, L-2, L-3, L-4, LONG-NAME-1, MAX, MIN, TOL, TYP
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.165. SYN-ARGUMENT

Description
This element describes one particular Argument within the current object synopsis. The name of the argument goes into <ITEM-LABEL>. The short description goes in to <DESC>. The detailed description goes into <ADD-INFO-5>.
Example
see 2.168. SYN-EXAMPLE
Formal Description
Within context of: | SYN-ARGUMENTS
Is context for: | ITEM-LABEL, DESC, ADD-INFO-5
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.166. SYN-ARGUMENTS

Description
This element taks all arguments of the objects described in the synopsis.
Example
2.168. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | SYN-ARGUMENT
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.167. SYN-CAPTION

Description
This serves to specify the caption of a particular synopsis similar to <TABLE-CAPTION>.
Example
2.168. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SYNOPSIS |
[F-NAMESPACE] fixed value | SGML string (NMTOKEN) | SYNOPSIS |


2.168. SYN-EXAMPLE

Description
This element is used to give an example how to use the object the <SYN-SYNOPSIS> is given for.
Example
2.168. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | DESC, ADD-INFO-5
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.169. SYN-FORMAT

Description
This element specifies the format how the object for which the <SYN-SYNOPSIS> is given. Note that the target name of the target-format ist described in the <P>.
Example
see 2.168. SYN-EXAMPLE
<SYN-FORMAT>
                  <P>usage in C++</P>
                  <VERBATIM>
                     x=mmx.execute("-S myfile.xml");
                  </VERBATIM>
                  <P>usage in Visual Basic</P>
                  <VERBATIM>
                     let x=mmx.execute("-S myfile.xml");
                  </VERBATIM>
                </SYN-FORMAT>
Formal Description
Within context of: | SYN-FORMATS
Is context for: | P, VERBATIM
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.170. SYN-FORMATS

Description
This element is a container for all the possible formats in which the object described in <SYN-SYNOPSIS> can be used.
Example
see 2.168. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | SYN-FORMAT
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.171. SYN-INCLUDE

Description
This element denotes the required inclusions required by the objects for which a <SYN-SYNOPSIS> is given.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | P
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.172. SYN-OBJECT

Description
This element is used to denote an object which is described in the current synopsis. The name of the object is given as <ITEM-LABEL>. The <P> are used to give a short definition of the main purpose of the object.
Example
see Example
Formal Description
Within context of: | SYN-OBJECTS
Is context for: | ITEM-LABEL, P
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.173. SYN-OBJECTS

Description
This element serves as a container to keep all <SYN-OBJECT>s in the Synopsis.
Example
Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | SYN-OBJECT
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.174. SYN-RETURN-VALUE

Description
This element describes the return value of the object for which the synopsis is given. <DESC> takes a short description used for overviews. <ADD-INFO-5> is used to give a full blown specification.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | DESC, ADD-INFO-5
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.175. SYN-SEE-ALSO

Description
This element is used to to give references to similar objects and additional reference material.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | P
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.176. SYN-SEMANTICS

Description
This element is used to specify the particular semantics of the objects for which a synopsis is given. <DESC> takes an quick description intended for overview tables. <ADD-INFO-5> takes a full blown specification.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | DESC, ADD-INFO-5
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.177. SYN-SYNOPSIS

Description
This element serves as a semiformal description of the Synopsis of an application arogramming interface. This is mainly intended to be used for generating a programmer's reference manual in MSRREP. Although there is some overlap with <SW-SERVICE> in the MSRSW-Context, this Element can be useful to specifiy a required API. Therfore <SYN-SYNOPIS> is located in free text elements on a paragraph level. <SYN-SYNOPIS> is made such that it can be redered similar to a <LABELED-LIST>. In this sense, <SYN-SYNOPSIS> can be considered as a specific form of a <LABELED-LST> .
Example
This example shows the source code of a routine called forceerror which takse three arguments.

                <SYN-SYNOPSIS>
                 <SYN-CAPTION ID="SYN.PROCEDURE.FORCEERROR">
                  <LONG-NAME>forceerror</LONG-NAME>
                 </SYN-CAPTION>
                 <SYN-OBJECTS>

                  <SYN-OBJECT>
                   <ITEM-LABEL>forceerror
                    <IE>procedure;forceerror</IE>

                    <IE>forceerror</IE>
                   </ITEM-LABEL>

                   <P>force an error</P>
                  </SYN-OBJECT>
                 </SYN-OBJECTS>
                 <SYN-FORMATS>

                  <SYN-FORMAT>

                   <P>
                    <E TYPE="ITALIC">subject</E>.forceerror(
                    <E TYPE="ITALIC">type</E>,
                    <E TYPE="ITALIC">code</E>,
                    <E TYPE="ITALIC">node</E>?)
                   </P>
                  </SYN-FORMAT>
                 </SYN-FORMATS>
                 <SYN-ARGUMENTS>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>subject</ITEM-LABEL>

                   <DESC>string</DESC>
                  </SYN-ARGUMENT>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>type</ITEM-LABEL>

                   <DESC>single string</DESC>
                  </SYN-ARGUMENT>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>code</ITEM-LABEL>

                   <DESC>single string</DESC>
                  </SYN-ARGUMENT>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>node</ITEM-LABEL>

                   <DESC>tree node</DESC>
                  </SYN-ARGUMENT>
                 </SYN-ARGUMENTS>

                 <SYN-RETURN-VALUE>

                  <DESC>null</DESC>
                  <ADD-INFO-5/>
                 </SYN-RETURN-VALUE>
                 <SYN-SEMANTICS>

                  <DESC>forces a warning/error... to be issued;

                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">subject</E> (which must evaluate to a
                                                string) is used as the message text;
                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">type</E> may be any string, e.g., "warning",
                                                "error" etc.,
                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">code</E> is
                                                used as the warning/error/.... code, e.g., "illegal input" etc.;

                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">node</E> the object to which the error
                                                node will be linked (the current target node if nothing is specified).
                  </DESC>

                  <ADD-INFO-5/>
                 </SYN-SEMANTICS>
                 <SYN-EXAMPLE>
                  <ADD-INFO-5>

                   <VERBATIM>: i "Wrong.\n".forceerror("INFO","ILLEGAL INPUT");</VERBATIM>

                   <P>returns the following output on stderr:</P>

                   <VERBATIM>FORCED-INFO (ILLEGAL INPUT):
                Wrong.
                null
                :</VERBATIM>

                  </ADD-INFO-5>
                 </SYN-EXAMPLE>
                </SYN-SYNOPSIS>
Formal Description
Within context of: | ADD-INFO-5, CHAPTER, MSR-QUERY-RESULT-P-1, TOPIC-1
Is context for: | SYN-CAPTION, SYN-OBJECTS, SYN-INCLUDE, SYN-FORMATS, SYN-ARGUMENTS, SYN-RETURN-VALUE, SYN-SEMANTICS, SYN-EXAMPLE, SYN-SEE-ALSO
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.178. TABLE

Description
Use <TABLE> to create a table.
Example
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, INTRODUCTION, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, TOPIC-1, TOPIC-2
Is context for: | TABLE-CAPTION, TGROUP
Name
Type
Values / Default
Notes
[TOCENTRY]
has default value
SGML string (NMTOKEN)
1
0 - no table heading <LONG-NAME> entered into the table directory. 0 - table heading <LONG-NAME> entered into the table directory.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[FLOAT]
optional
Value selection (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Permits a check, in the case of a <TABLE> that cannot be broken up, to determine whether the <TABLE> can be shifted elsewhere, so that the page can be used to a greater advantage (compare to flat at TeX).
[FRAME]
optional
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • TOPBOT
  • ALL
  • SIDES
  • NONE
TOP - graphic limit at upper edge of table. BOTTOM - graphic limit at lower edge of table. TOPBOT - graphic limit at upper and lower edge of table. ALL - graphic limit of all table edges. SIDES - graphic limit of side edges of table NONE - no graphic limits in table
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[ORIENT]
optional
Value selection (NAMEDTOKENGROUP)
  • PORT
  • LAND
PORT - table contents is parallel to the paragraph elements. LAND - table contents is at orthogonal to the paragraph elements.
[PGWIDE]
optional
SGML string (NMTOKEN)
0 - table width is the sum of the widths specified for the columns. 1 - table width corresponds to page width.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[S]
optional
String (CDATA)
[SHORTENTRY]
optional
SGML string (NMTOKEN)
0 - a <SHORT-NAME> is not taken over into the table directory 0 - table directory is assigned a <SHORT-NAME> .
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[TABSTYLE]
optional
SGML string (NMTOKEN)
Identification of an external table style
[VIEW]
optional
String (CDATA)


2.179. TABLE-CAPTION

Description
This element specifies the table heading.
Example
Formal Description
Within context of: | TABLE
Is context for: | LONG-NAME, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TABLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.180. TBODY

Description
Use <TBODY> to generate all of the rows in a table.
Example
Formal Description
Within context of: | TGROUP
Is context for: | ROW
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.181. TEAM-MEMBER

Description
Use <TEAM-MEMBER> to enter data on a project participant from a specific company.
Example
Formal Description
Within context of: | TEAM-MEMBERS
Is context for: | LONG-NAME, SHORT-NAME, ROLES, DEPARTMENT, ADDRESS, ZIP, CITY, PHONE, FAX, EMAIL, HOMEPAGE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.182. TEAM-MEMBER-REF

Description
<TEAM-MEMBER-REF> is the pointer to one particular team member. The content is the <SHORT-NAME> of the corresponding <TEAM-MEMBER> .
Example
For an example, see 2.5. ADMIN-DATA 2.5. ADMIN-DATA .
Formal Description
Within context of: | CHG-RESPONSIBLE, COMPANY-DOC-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.183. TEAM-MEMBERS

Description
Use <TEAM-MEMBERS> to enter data on all project participants from a specific company.
Example
Formal Description
Within context of: | COMPANY
Is context for: | TEAM-MEMBER
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.184. TEX-MATH

Description
Use <TEX-MATH> to insert a TeX formula. A TeX formula can be processed by a TeX or a LaTeX processor.
Example
Formal Description
Within context of: | FORMULA
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.185. TEXT

Description
Use <TEXT> to enter descriptive text into the cell of a parameter table.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | L-3
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.186. TFOOT

Description
Use <TFOOT> to create a footnote for a table.
Example
Formal Description
Within context of: | TGROUP
Is context for: | COLSPEC, ROW
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.187. TGROUP

Description
Use <TGROUP> to create a table group within a table.
Example
Formal Description
Within context of: | TABLE
Is context for: | COLSPEC, SPANSPEC, THEAD, TFOOT, TBODY
Name
Type
Values / Default
Notes
[COLS]
required
SGML string (NMTOKEN)
Enter the number of columns in the table group.
[ALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
has default value
String (CDATA)
If [ALIGN]="CHAR", this specifies the alignment sign e.g. "bzlw", as a decimal point separator from an existing value of [CHAR] . The sign cannot be a SDATA entity.
[CHAROFF]
has default value
SGML string (NMTOKEN)
50
If [ALIGN]="CHAR", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <ENTRY> , alignment is always horizontal right.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[TGROUPSTYLE]
optional
SGML string (NMTOKEN)
Identification of an external table group style
[VIEW]
optional
String (CDATA)


2.188. THEAD

Description
Use <THEAD> to create a heading for a table.
Example
Formal Description
Within context of: | TGROUP
Is context for: | COLSPEC, ROW
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.189. TOL

Description
Use <TOL> to enter the tolerance values of a parameter.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.190. TOOL

Description
This element describes the tool which was used to generate the corresponding <XFILE> .
Example
Formal Description
Within context of: | XFILE
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.191. TOOL-VERSION

Description
This element describes the tool version which was used to generate the corresponding <XFILE> .
Example
<XFILE ID="DC17723163279664">
                   <LONG-NAME-1>Praesentation</LONG-NAME-1>
                   <NOTATION>PowerPoint</NOTATION>
                   <TOOL>Microsoft PowerPoint</TOOL>
                   <TOOL-VERSION>2000</TOOL-VERSION>
                </XFILE>
Formal Description
Within context of: | XFILE
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.192. TOPIC-1

Description
Use <TOPIC-1> to generate a closed sense unit within a documentation.
Example
Formal Description
Within context of: | CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-TOPIC-1
Is context for: | LONG-NAME, SHORT-NAME, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, PRMS, MSR-QUERY-P-1
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
TOPIC
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.193. TOPIC-2

Description
Use <TOPIC-2> to generate a closed sense unit within a documentation.
Example
Formal Description
Within context of: | ABSTRACT, INTRODUCTION, MSR-QUERY-RESULT-TOPIC-2
Is context for: | LONG-NAME, SHORT-NAME, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
TOPIC
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.194. TT

Description
Use <TT> to format technical terms within the paragraph element.
Example
Formal Description
Within context of: | FT, L-1, L-2, L-4, LONG-NAME-1
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
required
Value selection (NAMEDTOKENGROUP)
  • SGMLTAG
  • SGML-ATTRIBUTE
  • TOOL
  • PRODUCT
  • VARIABLE
  • STATE
  • PRM
  • MATERIAL
  • CONTROL-ELEMENT
  • CODE
  • ORGANISATION
  • OTHER
Indicates a type of the respective element.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[USER-DEFINED-TYPE]
optional
String (CDATA)
Allows user-specific TTs to be introduced.
[VIEW]
optional
String (CDATA)


2.195. TYP

Description
Use <TYP> to enter the typical values of a parameter.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.196. UNIT

Description
Use <UNIT> to enter the unit of a parameter.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | L-3
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.197. URL

Description
This element specifies the Uniform Resource Locator (URL) of the context contained in the <URL> element.
Example
See 2.103. MATCHING-DCIS 2.102. MATCHING-DCI .
Formal Description
Within context of: | MATCHING-DCI, STD, XDOC, XFILE
Is context for: | Text
Name | Type | Notes
[MIME-TYPE] optional | String (CDATA) |
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.198. USED-LANGUAGES

Description
Use <USED-LANGUAGES> to enter all other languages, in addition to the document language, which are used an a document or a section of a document.
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | L-10
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


2.199. VERBATIM

Description
<VERBATIM> is a paragraph in which white-space (in particular blanks and line feeds) is obeyed. This enables basic preformatting to be carried out, which can even be displayed on simple devices. Behavior is the same as PRE in HTML .
Example
<VERBATIM>
                  This is the system to demonstrate, how CDF should work.

                  I make it in three lines to demonstrate, how VERBATIM works.
                </VERBATIM>
Formal Description
Within context of: | ABSTRACT, ADD-INFO-5, CHAPTER, CHG-REASON, CHG-RELEASE-NOTES, CHG-SOLUTION-CON, CHG-SOLUTION-PRO, CHG-SOLUTION-SPEC, CHG-SUBJECT, ENTRY, FIGURE, FORMULA, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, REMARK, SYN-FORMAT, TOPIC-1, TOPIC-2
Is context for: | L-5
Name
Type
Values / Default
Notes
[ALLOW-BREAK]
has default value
SGML string (NMTOKEN)
1
Checks whether page breaks may be included in a <VERBATIM> . NO-ALLOW-BREAK means that the user is responsible for confining the layout to a page.
[FLOAT]
optional
Value selection (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Permits a check, in the case of a <VERBATIM> that cannot be broken up, to determine whether the <VERBATIM> can be shifted elsewhere, so that the page can be used to a greater advantage (compare to flat at TeX).
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[PGWIDE]
optional
Value selection (NAMEDTOKENGROUP)
  • PGWIDE
  • NO-PGWIDE
PGWIDE: enables the contents of the current element to be formatted using the entire width of the page. This for example, is beneficial in the case of code containing more than 80 characters per line.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)


2.200. XDOC

Description
Use <XDOC> , to reference an external document.
Example
Formal Description
Within context of: | L-1
Is context for: | LONG-NAME-1, SHORT-NAME, NUMBER, STATE-1, DATE-1, PUBLISHER, URL, POSITION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XDOC | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.201. XFILE

Description
Use <XFILE> , to reference an external file.
Example
<P>Please refer to
                   <XFILE>
                      <LONG-NAME-1>Parameter Contents file</LONG-NAME-1>
                      <SHORT-NAME>0711paco</SHORT-NAME>
                      <URL>../pacos/0711paco.xml</URL>
                      <NOTATION>PaCo</NOTATION>
                      <TOOL>DDCL</TOOL>
                      <TOOL-VERSION>1.3</TOOL-VERSION>
                   </XFILE>
                </P>
Formal Description
Within context of: | L-1
Is context for: | LONG-NAME-1, SHORT-NAME, URL, NOTATION, TOOL, TOOL-VERSION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XFILE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.202. XREF

Description
Use <XREF> , to generate cross-references within the document.
Example
Formal Description
Within context of: | L-1, L-2, L-5, MSR-QUERY-ARG
Is context for: | Text
Name
Type
Values / Default
Notes
[ID-CLASS]
required
SGML string (NMTOKEN)
ID-CLASS. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <XREF IDREF="ID1" ID-CLASS="TEAM-MEMBER">...</XREF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[SHOW-CONTENT]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-CONTENT
  • NO-SHOW-CONTENT
CONTENT determines whether the contents of an element should be output
[SHOW-RESOURCE-LONG-NAME]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-LONG-NAME
  • NO-SHOW-LONG-NAME
Select SHOW-LONG-NAME to display the paragraph label of the reference target.
[SHOW-RESOURCE-NUMBER]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-NUMBER
  • NO-SHOW-NUMBER
Select SHOW-NUMBER to display the paragraph number of the reference target.
[SHOW-RESOURCE-PAGE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-PAGE
  • NO-SHOW-PAGE
Select SHOW-LONG-NAME to display the page number of the reference target.
[SHOW-RESOURCE-SHORT-NAME]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-SHORT-NAME
  • NO-SHOW-SHORT-NAME
Select SHOW-LONG-NAME to display the abbreviation of the reference target.
[SHOW-RESOURCE-TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-TYPE
  • NO-SHOW-TYPE
Select SHOW-TYPE to display the paragraph type of the reference target.
[SHOW-SEE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-SEE
  • NO-SHOW-SEE
Determines whether the fixed text "see" should be output.
[EXT-ID-CLASS]
optional
String (CDATA)
External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[ID-REF]
optional
ID reference (IDREF)
Reference to an element made unambiguous through an ID attribute value within the document.
[S]
optional
String (CDATA)
[SI]
optional
String (CDATA)
[T]
optional
String (CDATA)
[VIEW]
optional
String (CDATA)
[HYNAMES]
fixed value
SGML strings (NMTOKENS)
LINKEND ID-REF
HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME]
fixed value
SGML string (NMTOKEN)
CLINK
HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.203. XREF-TARGET

Description
This element specifies a reference target which can be scattered throughout the text.
Example
<P>Dieses Element spezifiziert ein <XREF-TARGET ID="DC92181212673206"><LONG-NAME-1>Verweisziel</LONG-NAME-1></XREF-TARGET> Verweisziel,
                welches in den Text eingestreut werden kann. </P>
Formal Description
Within context of: | L-1, L-2
Is context for: | LONG-NAME-1, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[S] optional | String (CDATA) |  |
[SI] optional | String (CDATA) |  |
[T] optional | String (CDATA) |  |
[VIEW] optional | String (CDATA) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XREF-TARGET | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.204. ZIP

Description
Use <ZIP> , to enter the zip code of the company address, of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) |
[SI] optional | String (CDATA) |
[T] optional | String (CDATA) |
[VIEW] optional | String (CDATA) |


Technical Terms

Element and Attribute Documentation
Technical Terms


A-Links

ABS | 2.1.
ABSTRACT | 2.2.
ADD-INFO-5 | 2.3.
ADDRESS | 2.4.
ADMIN-DATA | 2.5.
AREA | 2.6.
BR | 2.7.
C-CODE | 2.8.
CATEGORY | 2.9.
CHANGE | 2.10.
CHANGES | 2.11.
CHAPTER | 2.12.
CHG-ACTION | 2.13.
CHG-ACTIONS | 2.14.
CHG-CHAPTER | 2.15.
CHG-CONCLUSION | 2.16.
CHG-EFFORT | 2.17.
CHG-IMPLEMENTATION | 2.18.
CHG-IMPLEMENTATIONS | 2.19.
CHG-KEYWORD | 2.20.
CHG-KEYWORDS | 2.21.
CHG-OBJECT | 2.22.
CHG-OBJECT-REVISION | 2.23.
CHG-OBJECT-REVISION-REF | 2.24.
CHG-OBJECT-REVISIONS | 2.25.
CHG-OBJECTS | 2.26.
CHG-PRIORITY | 2.27.
CHG-PROPOSED-BY | 2.28.
CHG-REASON | 2.29.
CHG-RELATED-OBJECTS | 2.30.
CHG-RELATED-REQUESTS | 2.31.
CHG-RELEASE-NOTES | 2.32.
CHG-REQUEST | 2.33.
CHG-REQUEST-REF | 2.34.
CHG-REQUESTS | 2.35.
CHG-RESPONSIBLE | 2.36.
CHG-SOLUTION | 2.37.
CHG-SOLUTION-CON | 2.38.
CHG-SOLUTION-PRO | 2.39.
CHG-SOLUTION-SPEC | 2.40.
CHG-SOLUTIONS | 2.41.
CHG-STATE | 2.42.
CHG-SUBJECT | 2.43.
CITY | 2.44.
COLSPEC | 2.45.
COMMENT | 2.46.
COMPANIES | 2.47.
COMPANY | 2.48.
COMPANY-DOC-INFO | 2.49.
COMPANY-DOC-INFOS | 2.50.
COMPANY-REF | 2.51.
COMPANY-REVISION-INFO | 2.52.
COMPANY-REVISION-INFOS | 2.53.
COND | 2.54.
DATE | 2.55.
DATE-1 | 2.56.
DEF | 2.57.
DEF-ITEM | 2.58.
DEF-LIST | 2.59.
DEPARTMENT | 2.60.
DESC | 2.61.
DOC-LABEL | 2.62.
DOC-REVISION | 2.63.
DOC-REVISIONS | 2.64.
E | 2.65.
EMAIL | 2.66.
ENTRY | 2.67.
FAX | 2.68.
FIGURE | 2.69.
FIGURE-CAPTION | 2.70.
FORMATTER-CTRL | 2.71.
FORMATTER-CTRLS | 2.72.
FORMULA | 2.73.
FORMULA-CAPTION | 2.74.
FT | 2.75.
GENERIC-MATH | 2.76.
GRAPHIC | 2.77.
HOMEPAGE | 2.78.
IE | 2.79.
INDENT-SAMPLE | 2.80.
INTRODUCTION | 2.81.
ISSUED-BY | 2.82.
ITEM | 2.83.
ITEM-LABEL | 2.84.
L-1 | 2.85.
L-10 | 2.86.
L-2 | 2.87.
L-3 | 2.88.
L-4 | 2.89.
L-5 | 2.90.
L-GRAPHIC | 2.91.
LABEL | 2.92.
LABELED-ITEM | 2.93.
LABELED-LIST | 2.94.
LANGUAGE | 2.95.
LIST | 2.96.
LOCS | 2.97.
LONG-NAME | 2.98.
LONG-NAME-1 | 2.99.
MAIN-TITLE | 2.100.
MAP | 2.101.
MATCHING-DCI | 2.102.
MATCHING-DCIS | 2.103.
MAX | 2.104.
MIN | 2.105.
MODIFICATION | 2.106.
MODIFICATIONS | 2.107.
MSR-PROCESSING-LOG | 2.108.
MSR-QUERY-ARG | 2.109.
MSR-QUERY-CHAPTER | 2.110.
MSR-QUERY-NAME | 2.111.
MSR-QUERY-P-1 | 2.112.
MSR-QUERY-P-2 | 2.113.
MSR-QUERY-PROPS | 2.114.
MSR-QUERY-RESULT-CHAPTER | 2.115.
MSR-QUERY-RESULT-P-1 | 2.116.
MSR-QUERY-RESULT-P-2 | 2.117.
MSR-QUERY-RESULT-TEXT | 2.118.
MSR-QUERY-RESULT-TOPIC-1 | 2.119.
MSR-QUERY-RESULT-TOPIC-2 | 2.120.
MSR-QUERY-TEXT | 2.121.
MSR-QUERY-TOPIC-1 | 2.122.
MSR-QUERY-TOPIC-2 | 2.123.
MSRREP | 2.124.
NAMELOC | 2.125.
NMLIST | 2.126.
NOTATION | 2.127.
NOTE | 2.128.
NUMBER | 2.129.
OVERALL-TITLE | 2.130.
P | 2.131.
PHONE | 2.132.
POSITION | 2.133.
PRM | 2.134.
PRM-CHAR | 2.135.
PRMS | 2.136.
PUBLISHER | 2.137.
REASON | 2.138.
REMARK | 2.139.
REPORT-BODY | 2.140.
REPORT-HEAD | 2.141.
REPORT-REAR | 2.142.
REPORT-SUBJECT | 2.143.
REVISION-LABEL | 2.144.
REVISION-LABEL-P1 | 2.145.
REVISION-LABEL-P2 | 2.146.
ROLE | 2.147.
ROLES | 2.148.
ROW | 2.149.
SD | 2.150.
SDG | 2.151.
SDG-CAPTION | 2.152.
SDGS | 2.153.
SHORT-LABEL | 2.154.
SHORT-NAME | 2.155.
SPANSPEC | 2.156.
SPECIAL-DATA | 2.157.
Standard Attributes | 1.
STATE | 2.158.
STATE-1 | 2.159.
STD | 2.160.
SUB | 2.161.
SUB-TITLE | 2.162.
SUBTITLE | 2.163.
SUP | 2.164.
SYN-ARGUMENT | 2.165.
SYN-ARGUMENTS | 2.166.
SYN-CAPTION | 2.167.
SYN-EXAMPLE | 2.168.
SYN-FORMAT | 2.169.
SYN-FORMATS | 2.170.
SYN-INCLUDE | 2.171.
SYN-OBJECT | 2.172.
SYN-OBJECTS | 2.173.
SYN-RETURN-VALUE | 2.174.
SYN-SEE-ALSO | 2.175.
SYN-SEMANTICS | 2.176.
SYN-SYNOPSIS | 2.177.
TABLE | 2.178.
TABLE-CAPTION | 2.179.
TBODY | 2.180.
TEAM-MEMBER | 2.181.
TEAM-MEMBER-REF | 2.182.
TEAM-MEMBERS | 2.183.
TEX-MATH | 2.184.
TEXT | 2.185.
TFOOT | 2.186.
TGROUP | 2.187.
THEAD | 2.188.
TOL | 2.189.
TOOL | 2.190.
TOOL-VERSION | 2.191.
TOPIC-1 | 2.192.
TOPIC-2 | 2.193.
TT | 2.194.
TYP | 2.195.
UNIT | 2.196.
URL | 2.197.
USED-LANGUAGES | 2.198.
VERBATIM | 2.199.
XDOC | 2.200.
XFILE | 2.201.
XREF | 2.202.
XREF-TARGET | 2.203.
ZIP | 2.204.


Control elements

MSR-QUERY


OTHER

 | 2.177.
Special Data Group | 2.151.


Products

CDF | 2.103.
DCI | 2.102.
HTML | 2.199.
MSRREP | 2.177.
MSRSW | 2.177.
MSRSW.DTD | 2.103.
PACO | 2.103.


SGML Attributes

ACCESSKEY
2.6.
ALIGN
2.45. 2.67. 2.156. 2.187.
ALLOW-BREAK
2.199.
ALT
2.6.
BREAK
2.12.
CATEGORY
2.77.
CHAR
2.45. 2.67. 2.156. 2.187.
CHAROFF
2.45. 2.67. 2.156. 2.187.
CLASS
2.6. 2.101.
COLNAME
2.45. 2.67.
COLNUM
2.45.
COLOR
2.65.
COLS
2.187.
COLSEP
2.45. 2.67. 2.156. 2.178. 2.187.
COLWIDTH
2.45.
COORDS
2.6.
DOCORSUB
2.126.
EDIT-HEIGHT
2.77.
EDIT-WIDTH
2.77.
EDITFIT
2.77.
EDITSCALE
2.77.
EXT-ID-CLASS
2.125. 2.202.
F-BUILD
2.124.
F-CHILD-TYPE
2.48. 2.148.
F-ID-CLASS
2.12. 2.15. 2.22. 2.23. 2.24. 2.33. 2.34. 2.48. 2.51. 2.58. 2.70. 2.74. 2.125. 2.134. 2.152. 2.160. 2.167. 2.179. 2.181. 2.182. 2.192. 2.193. 2.200. 2.201. 2.203.
F-NAMESPACE
2.15. 2.22. 2.48. 2.124. 2.167.
F-PUBID
2.124.
FILENAME
2.77.
FIT
2.77.
FLOAT
2.69. 2.178. 2.199.
FONT
2.65.
FRAME
2.69. 2.178.
FUNCTION-REF
2.126.
GID
2.150. 2.151.
HEIGHT
2.77.
HELP-ENTRY
2.12. 2.58. 2.69. 2.93. 2.131. 2.178. 2.192. 2.193. 2.199.
HREF
2.6.
HTML-FIT
2.77.
HTML-HEIGHT
2.77.
HTML-SCALE
2.77.
HTML-WIDTH
2.77.
HYNAMES
2.24. 2.34. 2.51. 2.182. 2.202.
HYTIME
2.24. 2.34. 2.51. 2.124. 2.125. 2.126. 2.182. 2.202.
ID
2.6. 2.12. 2.15. 2.22. 2.23. 2.33. 2.48. 2.58. 2.70. 2.74. 2.101. 2.125. 2.134. 2.152. 2.160. 2.167. 2.179. 2.181. 2.192. 2.193. 2.200. 2.201. 2.203.
ID-CLASS
2.150. 2.202.
ID-REF
2.24. 2.34. 2.51. 2.150. 2.182. 2.202.
ITEM-LABEL-POS
2.80.
KEEP-WITH-PREVIOUS
2.12. 2.15. 2.58. 2.59. 2.69. 2.73. 2.83. 2.93. 2.94. 2.96. 2.110. 2.112. 2.113. 2.122. 2.123. 2.128. 2.131. 2.136. 2.178. 2.192. 2.193. 2.199.
L
2.85. 2.86. 2.87. 2.88. 2.89. 2.90. 2.91.
MIME-TYPE
2.197.
MOREROWS
2.67.
NAME
2.101.
NAMEEND
2.67. 2.156.
NAMEST
2.67. 2.156.
NAMETYPE
2.126.
NOHREF
2.6.
NOTATION
2.77.
NOTE-TYPE
2.128.
ONBLUR
2.6.
ONCLICK
2.6. 2.101.
ONDBLCLICK
2.6. 2.101.
ONFOCUS
2.6.
ONKEYDOWN
2.6. 2.101.
ONKEYPRESS
2.6. 2.101.
ONKEYUP
2.6. 2.101.
ONMOUSEDOWN
2.6. 2.101.
ONMOUSEMOVE
2.6. 2.101.
ONMOUSEOUT
2.6. 2.101.
ONMOUSEOVER
2.6. 2.101.
ONMOUSEUP
2.6. 2.101.
ORIENT
2.178.
PGWIDE
2.69. 2.178. 2.199.
PUBID
2.124.
RELATION
2.34.
ROLE
2.48.
ROTATE
2.67.
ROWSEP
2.45. 2.67. 2.149. 2.156. 2.178. 2.187.
S
1. 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 2.21. 2.22. 2.23. 2.24. 2.25. 2.26. 2.27. 2.28. 2.29. 2.30. 2.31. 2.32. 2.33. 2.34. 2.35. 2.36. 2.37. 2.38. 2.39. 2.40. 2.41. 2.42. 2.43. 2.44. 2.45. 2.46. 2.47. 2.48. 2.49. 2.50. 2.51. 2.52. 2.53. 2.54. 2.55. 2.56. 2.57. 2.58. 2.59. 2.60. 2.61. 2.62. 2.63. 2.64. 2.65. 2.66. 2.67. 2.68. 2.69. 2.70. 2.71. 2.72. 2.73. 2.74. 2.75. 2.76. 2.77. 2.78. 2.79. 2.80. 2.81. 2.82. 2.83. 2.84. 2.85. 2.86. 2.87. 2.88. 2.89. 2.90. 2.91. 2.92. 2.93. 2.94. 2.95. 2.96. 2.97. 2.98. 2.99. 2.100. 2.101. 2.102. 2.103. 2.104. 2.105. 2.106. 2.107. 2.108. 2.109. 2.110. 2.111. 2.112. 2.113. 2.114. 2.115. 2.116. 2.117. 2.118. 2.119. 2.120. 2.121. 2.122. 2.123. 2.124. 2.125. 2.126. 2.127. 2.128. 2.129. 2.130. 2.131. 2.132. 2.133. 2.134. 2.135. 2.136. 2.137. 2.138. 2.139. 2.140. 2.141. 2.142. 2.143. 2.144. 2.145. 2.146. 2.147. 2.148. 2.149. 2.150. 2.151. 2.152. 2.153. 2.154. 2.155. 2.156. 2.157. 2.158. 2.159. 2.160. 2.161. 2.162. 2.163. 2.164. 2.165. 2.166. 2.167. 2.168. 2.169. 2.170. 2.171. 2.172. 2.173. 2.174. 2.175. 2.176. 2.177. 2.178. 2.179. 2.180. 2.181. 2.182. 2.183. 2.184. 2.185. 2.186. 2.187. 2.188. 2.189. 2.190. 2.191. 2.192. 2.193. 2.194. 2.195. 2.196. 2.197. 2.198. 2.199. 2.200. 2.201. 2.202. 2.203. 2.204.
SCALE
2.77.
SHAPE
2.6.
SHORTENTRY
2.178.
SHOW-CONTENT
2.202.
SHOW-RESOURCE-LONG-NAME
2.202.
SHOW-RESOURCE-NUMBER
2.202.
SHOW-RESOURCE-PAGE
2.202.
SHOW-RESOURCE-SHORT-NAME
2.202.
SHOW-RESOURCE-TYPE
2.202.
SHOW-SEE
2.202.
SI
1. 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 2.21. 2.22. 2.23. 2.24. 2.25. 2.26. 2.27. 2.28. 2.29. 2.30. 2.31. 2.32. 2.33. 2.34. 2.35. 2.36. 2.37. 2.38. 2.39. 2.40. 2.41. 2.42. 2.43. 2.44. 2.45. 2.46. 2.47. 2.48. 2.49. 2.50. 2.51. 2.52. 2.53. 2.54. 2.55. 2.56. 2.57. 2.58. 2.59. 2.60. 2.61. 2.62. 2.63. 2.64. 2.65. 2.66. 2.67. 2.68. 2.69. 2.70. 2.71. 2.72. 2.73. 2.74. 2.75. 2.76. 2.77. 2.78. 2.79. 2.80. 2.81. 2.82. 2.83. 2.84. 2.85. 2.86. 2.87. 2.88. 2.89. 2.90. 2.91. 2.92. 2.93. 2.94. 2.95. 2.96. 2.97. 2.98. 2.99. 2.100. 2.101. 2.102. 2.103. 2.104. 2.105. 2.106. 2.107. 2.108. 2.109. 2.110. 2.111. 2.112. 2.113. 2.114. 2.115. 2.116. 2.117. 2.118. 2.119. 2.120. 2.121. 2.122. 2.123. 2.124. 2.125. 2.126. 2.127. 2.128. 2.129. 2.130. 2.131. 2.132. 2.133. 2.134. 2.135. 2.136. 2.137. 2.138. 2.139. 2.140. 2.141. 2.142. 2.143. 2.144. 2.145. 2.146. 2.147. 2.148. 2.149. 2.150. 2.151. 2.152. 2.153. 2.154. 2.155. 2.156. 2.157. 2.158. 2.159. 2.160. 2.161. 2.162. 2.163. 2.164. 2.165. 2.166. 2.167. 2.168. 2.169. 2.170. 2.171. 2.172. 2.173. 2.174. 2.175. 2.176. 2.177. 2.178. 2.179. 2.180. 2.181. 2.182. 2.183. 2.184. 2.185. 2.186. 2.187. 2.188. 2.189. 2.190. 2.191. 2.192. 2.193. 2.194. 2.195. 2.196. 2.197. 2.198. 2.199. 2.200. 2.201. 2.202. 2.203. 2.204.
SPANNAME
2.67. 2.156.
STATE
2.42.
STYLE
2.6. 2.101.
T
1. 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 2.21. 2.22. 2.23. 2.24. 2.25. 2.26. 2.27. 2.28. 2.29. 2.30. 2.31. 2.32. 2.33. 2.34. 2.35. 2.36. 2.37. 2.38. 2.39. 2.40. 2.41. 2.42. 2.43. 2.44. 2.45. 2.46. 2.47. 2.48. 2.49. 2.50. 2.51. 2.52. 2.53. 2.54. 2.55. 2.56. 2.57. 2.58. 2.59. 2.60. 2.61. 2.62. 2.63. 2.64. 2.65. 2.66. 2.67. 2.68. 2.69. 2.70. 2.71. 2.72. 2.73. 2.74. 2.75. 2.76. 2.77. 2.78. 2.79. 2.80. 2.81. 2.82. 2.83. 2.84. 2.85. 2.86. 2.87. 2.88. 2.89. 2.90. 2.91. 2.92. 2.93. 2.94. 2.95. 2.96. 2.97. 2.98. 2.99. 2.100. 2.101. 2.102. 2.103. 2.104. 2.105. 2.106. 2.107. 2.108. 2.109. 2.110. 2.111. 2.112. 2.113. 2.114. 2.115. 2.116. 2.117. 2.118. 2.119. 2.120. 2.121. 2.122. 2.123. 2.124. 2.125. 2.126. 2.127. 2.128. 2.129. 2.130. 2.131. 2.132. 2.133. 2.134. 2.135. 2.136. 2.137. 2.138. 2.139. 2.140. 2.141. 2.142. 2.143. 2.144. 2.145. 2.146. 2.147. 2.148. 2.149. 2.150. 2.151. 2.152. 2.153. 2.154. 2.155. 2.156. 2.157. 2.158. 2.159. 2.160. 2.161. 2.162. 2.163. 2.164. 2.165. 2.166. 2.167. 2.168. 2.169. 2.170. 2.171. 2.172. 2.173. 2.174. 2.175. 2.176. 2.177. 2.178. 2.179. 2.180. 2.181. 2.182. 2.183. 2.184. 2.185. 2.186. 2.187. 2.188. 2.189. 2.190. 2.191. 2.192. 2.193. 2.194. 2.195. 2.196. 2.197. 2.198. 2.199. 2.200. 2.201. 2.202. 2.203. 2.204.
TABINDEX
2.6.
TABSTYLE
2.178.
TARGET-SYSTEM
2.71.
TGROUPSTYLE
2.187.
TITLE
2.6. 2.101.
TOCENTRY
2.178.
TYPE
2.65. 2.79. 2.96. 2.106. 2.194.
USER-DEFINED-TYPE
2.128. 2.194.
VALIGN
2.67. 2.149. 2.180. 2.186. 2.188.
VIEW
1. 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 2.21. 2.22. 2.23. 2.24. 2.25. 2.26. 2.27. 2.28. 2.29. 2.30. 2.31. 2.32. 2.33. 2.34. 2.35. 2.36. 2.37. 2.38. 2.39. 2.40. 2.41. 2.42. 2.43. 2.44. 2.45. 2.46. 2.47. 2.48. 2.49. 2.50. 2.51. 2.52. 2.53. 2.54. 2.55. 2.56. 2.57. 2.58. 2.59. 2.60. 2.61. 2.62. 2.63. 2.64. 2.65. 2.66. 2.67. 2.68. 2.69. 2.70. 2.71. 2.72. 2.73. 2.74. 2.75. 2.76. 2.77. 2.78. 2.79. 2.80. 2.81. 2.82. 2.83. 2.84. 2.85. 2.86. 2.87. 2.88. 2.89. 2.90. 2.91. 2.92. 2.93. 2.94. 2.95. 2.96. 2.97. 2.98. 2.99. 2.100. 2.101. 2.102. 2.103. 2.104. 2.105. 2.106. 2.107. 2.108. 2.109. 2.110. 2.111. 2.112. 2.113. 2.114. 2.115. 2.116. 2.117. 2.118. 2.119. 2.120. 2.121. 2.122. 2.123. 2.124. 2.125. 2.126. 2.127. 2.128. 2.129. 2.130. 2.131. 2.132. 2.133. 2.134. 2.135. 2.136. 2.137. 2.138. 2.139. 2.140. 2.141. 2.142. 2.143. 2.144. 2.145. 2.146. 2.147. 2.148. 2.149. 2.150. 2.151. 2.152. 2.153. 2.154. 2.155. 2.156. 2.157. 2.158. 2.159. 2.160. 2.161. 2.162. 2.163. 2.164. 2.165. 2.166. 2.167. 2.168. 2.169. 2.170. 2.171. 2.172. 2.173. 2.174. 2.175. 2.176. 2.177. 2.178. 2.179. 2.180. 2.181. 2.182. 2.183. 2.184. 2.185. 2.186. 2.187. 2.188. 2.189. 2.190. 2.191. 2.192. 2.193. 2.194. 2.195. 2.196. 2.197. 2.198. 2.199. 2.200. 2.201. 2.202. 2.203. 2.204.
WIDTH
2.77.


SGML Elements

ABS | 2.1.
ABSTRACT | 2.2.
ADD-INFO | 2.3.
ADD-INFO-5 | 2.3. 2.165. 2.174. 2.176.
ADDRESS | 2.4.
ADMIN-DATA | 2.5. 2.47. 2.64.
AREA | 2.6.
C-CODE | 2.8.
CATEGORY | 2.9.
CHANGE | 2.10.
CHAPTER | 2.12. 2.15. 2.108.
CHG-CHAPTER | 2.15.
CITY | 2.44.
COLSPEC | 2.45. 2.67. 2.156.
COMMENT | 2.114.
COMPANIES | 2.47.
COMPANY | 2.48.
COMPANY-DOC-INFO | 2.49.
COMPANY-DOC-INFOS | 2.50.
COMPANY-REF | 2.51.
COMPANY-REVISION-INFO | 2.52.
COMPANY-REVISION-INFOS | 2.53.
COND | 2.54.
DATE | 2.55. 2.56. 2.64.
DATE-1 | 2.56.
DEF | 2.57.
DEF-ITEM | 2.58.
DEF-LIST | 2.59.
DEPARTMENT | 2.60.
DESC | 2.61. 2.165. 2.174. 2.176.
DOC-LABEL | 2.62.
DOC-REVISION | 2.63. 2.64.
DOC-REVISIONS | 2.64.
E | 2.65.
EMAIL | 2.66.
ENTRY | 2.67. 2.156. 2.187.
FAX | 2.68.
FIGURE | 2.69.
FORMATTER-CTRL | 2.71. 2.72.
FORMULA | 2.73.
FT | 2.75.
GENERIC-MATH | 2.76.
GRAPHIC | 2.77.
HOMEPAGE | 2.78.
IE | 2.79.
INDENT-SAMPLE | 2.80.
INTRODUCTION | 2.81.
ITEM | 2.83. 2.96.
ITEM-LABEL | 2.84. 2.165. 2.172.
LABEL | 2.92.
LABELED-ITEM | 2.93.
LABELED-LIST | 2.93. 2.94. 2.177.
LABELED-LST | 2.177.
LANGUAGE | 2.95.
LIST | 2.83. 2.96.
LOCS | 2.97.
LONG-NAME | 2.92. 2.98. 2.152. 2.178.
LONG-NAME-1 | 2.99.
MAP | 2.101.
MATCHING-DCI | 2.102.
MATCHING-DCIS | 2.103.
MAX | 2.104.
MIN | 2.105.
MODIFICATION | 2.10. 2.106.
MODIFICATIONS | 2.107.
MSR-QUERY-ARG | 2.114.
MSR-QUERY-NAME | 2.109. 2.114.
MSR-QUERY-PROPS | 2.110. 2.112. 2.113. 2.121. 2.122. 2.123.
MSR-QUERY-RESULT-CHAPTER | 2.110.
MSR-QUERY-RESULT-P-1 | 2.112. 2.116. 2.117.
MSR-QUERY-RESULT-P-2 | 2.113. 2.116. 2.117.
MSR-QUERY-RESULT-TOPIC-1 | 2.122.
MSR-QUERY-RESULT-TOPIC-2 | 2.123.
MSR-QUERY-TEXT | 2.118. 2.121.
NAMELOC | 2.125.
NMLIST | 2.126.
NOTATION | 2.127.
NOTE | 2.128.
NUMBER | 2.129.
P | 2.10. 2.81. 2.131. 2.139. 2.169. 2.172.
PHONE | 2.132.
POSITION | 2.133.
PRM | 2.134.
PRM-CHAR | 2.135.
PRMS | 2.116. 2.117. 2.136.
PUBLISHER | 2.137.
REASON | 2.138.
REMARK | 2.139.
REPORT-BODY | 2.15.
REVISION-LABEL | 2.144.
REVISION-LABEL-P1 | 2.145. 2.146.
ROLE | 2.147.
ROLES | 2.148.
ROW | 2.149.
SD | 2.150. 2.151.
SDG | 2.151. 2.152. 2.153. 2.157.
SDG-CAPTION | 2.151.
SHORT-NAME | 2.151. 2.152. 2.154. 2.155. 2.178. 2.182.
SPANSPEC | 2.67. 2.156.
STATE | 2.158.
STATE-1 | 2.159.
STD | 2.160.
SUB | 2.161.
SUBTITLE | 2.163.
SUP | 2.164.
SW-SERVICE | 2.177.
SYN-OBJECT | 2.173.
SYN-SYNOPIS | 2.177.
SYN-SYNOPSIS | 2.168. 2.169. 2.170. 2.171. 2.177.
TABLE | 2.178.
TABLE-CAPTION | 2.167.
TBODY | 2.180.
TEAM-MEMBER | 2.82. 2.181. 2.182.
TEAM-MEMBER-REF | 2.47. 2.182.
TEAM-MEMBERS | 2.183.
TEX-MATH | 2.184.
TEXT | 2.185.
TFOOT | 2.186.
TGROUP | 2.45. 2.187.
THEAD | 2.188.
TOL | 2.189.
TOPIC-1 | 2.119. 2.192.
TOPIC-2 | 2.120. 2.193.
TT | 2.194.
TYP | 2.195.
UNIT | 2.196.
URL | 2.102. 2.197.
USED-LANGUAGES | 2.198.
VERBATIM | 2.81. 2.139. 2.199.
XDOC | 2.200.
XFILE | 2.190. 2.191. 2.201.
XREF | 2.151. 2.202.
ZIP | 2.204.


Tools

CDF processor
2.103.